Rendering layers - strange behavior

I have divided my model of a building into layers. Layers with decorations cover layers with base geometry. I would like to get a set of images (at once) with accumulatively enabling the layers:

  1. image with layer 0
  2. image with layers 0,1
  3. image with layers 0, 1, 2

By this, one can see how the decorations blend in.

For that I have created respective render layers, however something is wrong there. If I render just the first image with only the first layer selected, the parts covered by other layers with Z closer to the camera get rendered black. I have tried playing round with various settings, but without any success. I tried setting Mask Layers to this particular layer and to all the other layers, but I did not get the desired result. With All Z enabled, the solid black color changed to transparent so that the background became visible. Can you please give me a hint how to always render ONLY the content of the respective layer without the black parts standing for “there is something covering this in another layer”? I figured out it can be manually achieved by activating a single scene layer only, but I need to render 12 images at once instead of switching the layers one by one.

Attached is the ground truth (achieved by manually setting a single visible scene layer) and the wrong result image as described above. I will be grateful for any suggestions.