Rendering problem that I can't fix :(

Hello everyone :slight_smile:

I have a rendering issue that I cannot seem to fix. The image rendered when pressing F12 shows errors on the belt, collar, neck and upper arm area of a model that I am working on. I have already tried the “recalculate normals outside” option, as well as the “set smooth” option and I have also used the “remove doubles” option for the vertices. I also used shift+E to ensure that all of the edges on the model were soft. All of these options made no difference whatsoever to the results I get when rendering the model with F12. Can anyone tell me what I’m overlooking?


Check you haven’t any faces inside your mesh.
Try Ctrl+A to reset your objects scale.
Actually check the directions of your face normals, don’t assume that Ctrl+N will fix it in all circumstances.
Without actually seeing your blend, this is all just guessswork. If you have a problem it is always best to attach your blend file to your post. It makes finding a solution so much easier for those trying to help you.

Here is the Blend file. Hopefully someone can figure out what’s wrong :slight_smile:

EDIT: Can’t seem to upload the file, gimme a sec lol

OK hopefully it worked this time :s

Sorry guys, I can’t seem to be able to upload the .Blend file, so you will have to make do with that picture :frowning: Maybe I just can’t see my own attachments, I don’t know, all I know is that I waited for the upload to complete before closing that little window where you choose the location of the attachments - if you can see it, great, but I can’t see it attached to my previous 2 posts here - sorry bout that - I tried :frowning:

Could be some doubles that you forgot to remove that are intersecting with part of your mesh. Definitely check your normals though. If you have any modifiers on, especially subsurf, try switching around it’s position in the modifier stack and see if that helps.

There’s no doubles anywhere, and I’ve already checked all the normals - that’s why the problem is strange enough for me to post here :frowning: I have just made the normals visible and checked them all by eye, and they are definitely facing the correct way. I’ve also made sure that all the edges are soft, and I’ve also checked to make sure that I don’t have any vertices linked behind the visible surface area of the mesh. I am not using any modifiers.

Yet I still have issues with the final render as shown in the image in my 1st post.

What makes me so frustrated about this is that the exact same thing happened on a previous build of mine that took a whole month to build, and I was unable to figure out what was wrong back then too, and I was forced to abandon it and start again from scratch. The current model where this has happened again has also taken me about a month to create. I really don’t want to abandon it again. I really, REALLY need to find out why this keeps happening, or I will have to switch to Maya or 3D Studio Max instead :frowning:

You really need to attach your blend if you want this sorted. If it won’t attach to your post its usually becasue its too big. Rip out any textures and anything else not relevant.

I personally don’t care what software anyone uses, you should only use that which you’re comfortable with. If you’re not satisfied with blender and you’re happier with other alternatives you should use them.

So far, the model is just one mesh with one material with no textures. I’ve now removed most of the vertices except for the areas that I’m having issues with, and also removed a few other objects that were in the file. Looks like it’s uploaded successfully this time :smiley:

To be honest I would prefer to stick with Blender to create my models. The decision to switch to other software hinges on whether I can discover what is going wrong with my work whenever this rendering problem arises.


ProblemSomewhere2.blend (553 KB)

When I click your link I get

Invalid Attachment specified

Sorry, I modded the wrong file - I’ve added the right one now, and the download should work - I just checked it

As a quick look, turn off Autosmooth for starters, this is giving the artifacts on the sleave. If you want to control smoothing to give specific sharp edges, just like autosmooth but in a more controlled manner, use an edge-split modifier.
Smoothing sharp edges like on the collar never works well. Have you tried adding a subsurf modifier just at level 1 to ease the smoothing.

Well, the subsurf modifier seemed to fix the glitches perfectly… however, I now have two problems…

  1. I don’t want to have a subsurf modifier
  2. I still have no answer as to why the hard edges are appearing on the renders

If I don’t find out why this is happening, then I am quite sure that the same problem will happen again and again in the future. I just checked the rear of the model and found the same issue all over her back. This sucks, as I now have to check all the models I’ve previously made to see if they are at fault too.

I don’t want to have to keep adding a subsurf modifier to my models every time this issue occurs; this particular model had over 10 thousand vertices already, before the modifier was used. Now my PC is slowing down while I’m editing the model :frowning:

Does anyone have any idea why the model ended up in the state shown in the pic in my first post??

Richard nailed it. Turn off autosmooth.