rendering/shadow issues on a 40mb blend


so heres my problem:

i imported a huge 3ds from acad (a model of a building in a city with streets curbs etc)…the blend was originally 81 mb, i selected the complex meshes and just got rid of the duplicate verts and its down to 40 now.

so i have this model, when i send the “city”(buidings and stuff) to another layer and just render the main bulding, it turns out fine with shadows in the right place an even and everything…buuttt when i turn everything on then all the shadows in the model get all jagged and have a large amount of triangular gaps in a definite pattern.

whats the deal? same problem with blender internal and yafray…ray shadows and buffered…???

(i also tried putting one light in the layer with the main building and setting it to only put shadows in its layer, then i put the other light in the other layer with the city and told it to only shadow its layer…but the same exact problem exists.)

<tried using all lights that casts shoadows, at distance 380, energy 1, ray shadow> the shadows

pleeezzz somebody help me or give me a little direction…

i dont have a ton of experience with blender - does it have problems rendering scenes with a tone of verts (40mb)? is 40mb just way too huge, i don’t know…

here are the screenshots and renders of my problem…heeellllppppp :frowning:


I think you are using the new 2.40-version. This version seems to have some rendering-problems. In my case an animation renders random pictures like this :

yeah im using 2.4…u seem to have the same problem - but my problem only happens when i have all my layers on - when i limit whats “on” in the blender space then my render goes ok…im uploading my blend now…

Be sure you don’t have any models that have been doubled… also, I think if some of the meshes are more than 64k vertices, blender may have broken them up into smaller size meshes ina avery strange way that it does.

Usually, patterns of black = two object occupying the same space at the same time.

the blend is here:

the stuff is separated by layer

holy triangles batman!
go into every mesh and Alt-J to convert tris to quads where applicable (select all verts first).
Make sure OSA is on. (F10 render panel options).
Autocad makes overabundant use of verts because it thinks its cool (?). It also has a tendency to not have all of the edges connected with a face as we would normally like to see - these holes (not sure if this is what non-manifold means) makes some unsightly artifacts on rendering. Where possible, replace flat simple surfaces (like ground plane) with a new plane. This will make texturing/coloring easier too.

Blender just crashed on me while converting tris in the smaller buildings to quads - that’s a big mesh. Separate it into smaller mesh objects first (select verts, then hit p to separate (in edit mode).

edit: Doing the above things dropped your file size from 37.8 to 27.9 MB. with roughly 100K fewer polygons/faces. If you select “compress file” from the file menu, it helps with file size (doesn’t affect your model though).

wow man awesome! im doing what u suggested right now - im using cambo’s script for tri->quads…its pretty powerful huh!

so how did it render for you - do you get those jacked up shadows like i did? is rendering actually that related to vertice counts and stuff??

I don’t have any messed up shadows (before with original or with cleaned up). I think what you are referring to is a lack of OSA or anti-aliasing. Yes vert count effects render times, due to RAM. Shouldn’t effect your render quality though, unless you had some overlapping faces.

u know what? all this time i never restarted my computer (just blender) after i restarted my computer…the shadow problem stopped, even with my anti-aliasing off (can having OSA off really put holes in shadows?)

what in the world is up with THAT!!!..sometimes blender really really really confuses me.

thanks for all your help dude.

These little triangles are a problem of the renderer of blender 2.40 (in my case). If i render the pictures manually i don’t get any faulty pictures, but when i use animation rendering, every second picture gets these triangles. There are no doubled meshes, the count of triangles/quads is not high.
The problem seems to be some memory-crash while rendering, this is a bug, not a feature … :slight_smile: