Rendering shadow-only smoke in Cycles (NOT domain shadow issue)

Hey everybody!

Can we somehow render only the shadow of smoke simulation in Cycles?

I have lights, shadow catchers and smoke (domain and emitter). When smoke itself is visible, all is fine, we have a deep dark shadow of it: pic 1.
But when, e.g., I turn off camera visibility in domain Cycles settings, shadow disappears as well as the smoke does: pic 2

So, are there any ways to render the correct shadow without rendering smoke which causes it?

Go onto the object settings of your smoke, find the cycles settings and untick camera. Your smoke object is now invisible to the camera, but visible for the sake of shadows, reflection, and everything else.

Already done - with the result on the pics. Emitter Cycles settings doen’t affect the render visibility. Domain camera turn-off causes vanishing the whole thing from view (including shadow).

Sorry… can you do this with a Lightpath Node in the material nodes?

Not shure enough where to connect this node and with what option. “Is camera” or “is shadow” connected to last Add Shadrer node or to Output surface didn’t give the result. Could you please advise where to use the Light Path?

Not sure what you’re trying to accomplish, I usually don’t do volumetrics. But the ray outputs (added or multiplied?) should go into the fac input of a mix shader rather than an add shader. I’m guessing in this case, the first shader input should be empty (do nothing), and your shader setup into the second shader input - so, do this if seen by this and/or that and don’t do anything for anything else (maybe a transparent shader?).

1 Like

Shouldn’t it be like this?


Yeah. I’m not sure you even need the transparency shader though.

1 Like

Yep. That totaly workerd (I mean your idea and Acrivec’s pic explanation). Thanks for fine knoledge guys! Transparency is really not needed btw, as far as for my current scene.

No input would mean holdout shader, so it may not work always