Rendering stl file problem

I recently started using Blender and so far really like the program. But I have one problem I cannot figure out. When working with stl files from PTC Creo and applying some specific steel material (, all of the triangles of the stl file seem to be rendered individually. I tried reading about smooth shading and was looking for similar problems but could not find any. Honestly, I do not know what to look for exactly. The only solution I could find so far, was to apply a remesh modifier with Octree Depth 8. Then all looks well, but I have way to many faces then. Maybe the problem is related to the normals of the triangles? I attached the blend file and two screenshots and would be greatful to anyone who can point me into the right direction. Is it generally bad to use stl files? Should I export something else from CAD? Or is there some option in the material that is causing this problem?

Thanks for your help!


steel_part.blend (1.19 MB)

The material is using “Tangent Shading”, which AFAIK depends on the object’s UV coordinates - unfortunately the object is not UV unwrapped at all. The bump map is set to use those non-existant UV coordinates as well, btw. In addition to that the mesh has unapplied scale and rotation.

What might help:
a) Set shading to “Smooth” and add an Edge Split modifier.
b) Hit Ctrl-A > Rotation and Scale to apply both to the mesh.
c) Hit Tab to enter Edit mode, A to select all and then U > Cube Projection to create quick and dirty UV coordinates.

What will certainly help:
Use Cycles…:wink:

Very quick Cycles material/lighting setup:

Thank you very much, appreciate it :slight_smile: