Rendering with a movie background shows inconsistent results

I’m having inconsistent results rendering a sequence with a movie background.

The problem is that when rendering with a scene overlaid on top of a movie, the movie gets whitish on second render forward. Yes, the first render of the frame shows the movie fine, but the second one forward gets the white tinge.

To render another frame without the white “effect”, I have to click the movie and go to Strip -> Rebuild Proxy and Timecode Indices. Then again a single frame is rendered right, but the next ones go wrong again.

The strange thing is that I’ve tried with a different video, made with a different process, and it goes without the tinge.

I’ve attached the .blend file the zipped movie strip.

Attachments (118 KB)teste.blend (557 KB)

Your .avi is corrupted.

It opens fine here (in Media Player Classic - HC, VLC, Windows Media Player and Blender itself). The .avi is indeed very short. I cut it down just to show the problem.

Anyway, here are renders of the first render (normal):

and the other renders (whitish):

Adding them together in GIMP and inverting one of them and turning opacity to 50%, you can see that they are different (if you don’t see the white tinge right away).

It looks like the problem is some sort of bug in the video scaling.

I found two workarounds:

  1. In this case, the video and the render were 1024x768. If I increased or decreased one pixel in any direction, the problem was gone.

  2. In this process, I found that enabling the “Image Offset” option of the strip disabled the auto-scaling and the problem vanished too (without changing the render size).

It may help if you convert movie to image sequences and then work on those images instead of a movie clip

Kind of defeats the purpose of having a movie strip.

If I ignore the amount of disk space that I’ll lose in the process, does the image strip automatically load the sequence or must I put one strip for each frame?

How about using tracking features? The image sequence can be loaded automatically and you track something in the image/movie and place your model on top of the image
check this tracking tutorial

It was a bug, fixed in r61229, thanks for reporting ronanpaixao :slight_smile: