Rendering with GPU only, but uses very little of it

I’m having this problem for quite some time with all of my projects. When I’m trying to render an image or animation (I’m rendering with GPU only because it’s the fastest way for me), the beginning gets rendered really quickly, but after a short time later (when the render is finished at 15%), the process becomes really slow, until the end. I have posted details about my machine and the reference photo too below:

My specifications:

  • Processor - Intel® Core™ i7-9750H CPU @ 2.60GHz 260GHz;
  • RAM - 8.00 GB (during rendering, it only uses ~500 MB);
  • The program is installed on SSD disc;
  • Windows 10 Home 64 bit (version 1809);
  • GPU - NVIDIA GeForce GTX 1650 6 GB.

My render image: enter image description here

As you can see, very little of the GPU is used, which is why I think the rendering is slow…

What are your GPU temps once it hits 15% or so? Maybe your GPU is throttling down because it is getting too hot. I don’t have this problem myself, since all three of my 2070 Supers are Hybrids, and I have a massive case with 240mm fans and pretty kickass airflow… but in my 7 years of GPU rendering I have seen many folk run into GPU heat issues, so it is common…

I’ve seen with a maximum 80 celsius for the GPU when rendering, but when I touch the surface it isn’t really hot, though fans do work rather noisy. But when playing high-end games, the temperatures go even higher, but the performance never drops even though the settings are set at its highest. I think there might be some settings in Blender that I messed up and now it affects all of my projects…

switch to performance tab and switch one of graphs to CUDA

or even better download gpu-z and show graphs:

I know you said you are rendering with GPU only, but i have the same thing when rendering both cpu + gpu. In blender preferences > system > cuda section, makes sure the CPU is unchecked.

If it is checked, even when cycle say only GPU compute, it uses both.

yup, I have that unchecked, I’ll probably will never use CPU again.

Shot taken when the render was at 25%:

If you ruled out temperature, I would try with a clean blender preference, then maybe a gpu driver clean install.

Does it happen when you load the system with something else ? like a game or a benchmark ?

It looks ok,

GPU usage is 100%, GPU Temp is ~72℃, GPU Clock is ~1750 MHz,
and there is still avilable vram

Do not look at Windows default GPU Usage when doing some GPGPU, it might does not get it right when you use it in no gaming alike computations (so in eevee it may show correct %, but in cycles it does not).

Clean blender preference? How do you do that? I’ve just did a clean install for GPU, and updated to a new version that I missed, but no luck with the rendering. I’ve tried MSI benchmark, it looked smooth, no stuttering or something, so Blender is the “suspect” here.

Sigh, I think I’ll try rendering with eevee next time.

File > defaults > factory settings.
https://docs.blender.org/manual/en/latest/advanced/blender_directory_layout.html

Or you can try to download the portable version from blender.org directly.

Note that: I’m not saying that You should use eevee, or Your GPU is not used at 100% (it is used as Your GPU-Z screen shows),
but:

Windows Manager is not reliable source to get GPU Usage information.

1 Like

Ok, so after doing the factory reset, something interesting happened. After doing that, and tried to do a render, the render cube things were smaller (default size I think) than I used before, and the image was generated almost instantly. But the render speed didn’t improve a lot, after the image was rendered (on 10%), the process slows down when removing noises, adding quality, details and so on.

the render cube thing is called tilesize. it’s in render properties, performance tab.

it should set small for cpu (32x32) ish and bigger for gpu (256x256) ish.
There’s an addon shipping by default with blender, it’s called auto tile size. Just have to enable it in blender preference > add-ons.

Could you upload a scene having the problem ?

Yup, I had the add-on on, and I rendered with it while trying out all of the features, nothing really affected the performance. Though, after the factory reset, it disappeared, but I’ll get it back later.

Note - I took this pic after the factory reset, I didn’t touch a single setting and went straight with rendering. Like I mentioned before, the image (just like in this screenshot), got rendered super fast, after that, it started to denoise every tile, and then it tried to compile every tile (which I think the program is doing unnecessary things). I double checked the render settings, subdivisions were set to 3, glossy, transmission were set off too and all the other things I was told to do.