Retopo MT for Blender 2.80

I agree with the others users, the addon is really slow now, can we break it down into small addons and remove some extra feature if it will speed it up?

Hi @erickBlender.

I would be curious to know the performance statistics that you get on your computer while using Retopo MT.

  1. Would you mind sharing your computer specs (CPU-Z can help you know them: https://www.cpuid.com/softwares/cpu-z.html)

  2. Would you agree to tell me the maximum polygons you can work on, with Retopo MT?

Thank you in advance.

My spec Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 550 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 376.54
and the number poly varies from base mesh ( 50k-400k) and one thing that i m doing more often in Blender 2.8 is breaking mesh into small pieces
Some of my processes Erick sculptember fun

1 Like

I am bit surprised, and confused. :hushed: :thinking:

With a GeForce GTX 550 Ti, you can work (relatively well, right?) on a mesh composed of 50k-400k?
What’s the amont of polygons that makes Blender really slowdown or freeze?

I can not work with a mesh composed of 7,000 polygons (or it’s a PITA). Something must be wrong on my end. I don’t understand. :face_with_raised_eyebrow:

PS : I am not blaming Retopo MT for this bad performance (even if, I think there might be room for performance improvements, but I am sure cwolf3d has been working on this issue). I am just wondering if something is bad on my rig or on my OS.

What do you mean by mesh composed of 7k polygons? are you talking about the base mesh or the retopoed one?

For comparison, you can try using the original script for the Blender version 2.79.

And see for yourself that now this script works twice as fast as the original one.

Maybe you can still speed up this addon. But basically it depends on the fact that the data for display through gpu is prepared in python.

3 Likes

The amount of poly that slow Blender down here in my rig depends on the mode :

  • I keep my mesh between 20k-50k if i know i will be doing modifications in edit mode.
  • In sculpt mode with dyntopo sculpt i keep it below 200k but with multires. less 20M
  • In texture paint and vertex paint 20K-50K long ago use this modes, i didn’t stressed them lately.
  • Animation i usual use the base mesh

Good idea, I will test it soon. :+1:

Yes, I am talking about the base mesh. :cry:

If I enable Retopo MT:
7000 faces is about the maximum number of faces that I can work with, because in this case, the viewport is about 13-15 FPS (it’s a bit difficult to work but it’s still usable).

But when I normally work in Edit mode, as usual (without Retopo MT activated):
On Blender 2.82a: if I load a high-poly mesh (1.7 million faces), I can work on it in Edit and Sculpting modes without any “real” problem.
I can rotate the viewport very fast. Nonetheless, with 1.7 million faces, it takes 6-7 seconds to switch from Edit mode to Object mode (and vice versa).
And selecting vertices on this high-poly mesh lags a little (3 seconds for the selection to appear). But the viewport is still responsive.

3 Likes

For good, need to implement the basic concepts from this addon in C++ directly in the blender in edit mode. For example as knife is acting now. Click on the button and draw polygons on the model surface. Click on another button and draw the guides for the polygons (BSurface mode).

Such additions are good for checking the concept, and if they are in demand, it is advisable to transfer to something more productive.

4 Likes

This would be really helpful, the problem is now who is willing to implement that in C?

1 Like

I see now with RetopoMT activated, i honestly didn’t track when blender starts to lag. I will look at it in near future ( first i should find something exciting to sculpt). My comment above is more the general rule that i set for myself.

I have should give the credit, i started new retopo of an old sculpt with the latest retopo MT, it is really fast compare to old one ( i didn’t test the old one just feeling from memory), but i will give it good swing and see how it will deal with it.
It is clear that the number of vertices is weighing on the speed.

Addon updated. v. 2.1.5 (08-05-2020):
Slightly increased speed.
Fixed selection and editing (merge) of invisible vertices (vertices on the other side of the object).
Vertex selection is excluded from the Undo system.
Added deselection of vertices (Alt + C).

5 Likes

Hi, I’m gonna start learning sculpting and then retopology.
Is this improved version of BSurfaces or it has some different workflow?
Would you recommend this or your port of BSurfaces?

1 Like

Use two. BSurfaces and Retopo MT. One does not interfere with the other. You will see what will be more convenient for you.

im not sure if this is the problem ,

are you pressing Shit+Ctrl+Alt+X while in edit mode of your highpoly mesh ?
if yes, this might be the cause.

Shit+Ctrl+Alt+X is to be pressed in edit mode of another object( plane for retopo or empty object)

i made this istake previously and got performance drop.almost couldnt do anything and aslo went to wireframe.

Thanks for this addon, please is there a way to fix this problem? im unable to use the tool.

1 Like

Mysterious mesh. Can’t reproduce the problem. I tried it with different not applied modifiers and transferred pivot and with not applied scale and sculpt, the addon handles everything correctly.

wow, i tried importing another mesh but got same problem. only works with bblenders primitive mesh for me .

i have attached the mesh file if you can try it out .
thanks for the feedback .

jacket.rar (3.0 MB)

The reason is that the object is rotated 90 degrees along the X axis. After applying the rotation, everything works fine.
Thanks for testing, I will release a version of the add-on later with a fix for this behavior.

1 Like