Rigging does not work on model

I am trying to rig a .OBJ file I have sculpted on Z brush, however no matter what I try rigging does not work. I have checked all possible options I could possibly think of from remaking the model, lowering its poly count, checking for non-manifold faces, etc… Whenever I try to parent it (CTRL+P) with automatic weights it does not work.

I have attached the file below, if you had this before or have any suggestions please help!


Your metarig is incorrect / bugged. Could fix it by:

Applying rotation and scale on the baby.
Removing the old rig.
Adding an armature > basic > basic human. Placing the bones correctly with snapping to volume (center).

Pressing Generate rig in the armature tab ( at the bottom ). It will compute a bit and generate a new rig (named rig).
You can delete the one called metarig at this stage.

Now, select the baby then the rig then parent it with automatic weight.

It should work now. You will have the layer control in the n-pannel.

If you need a more complete rig, it is the same procedure will all the rigify. Add rig, place bones, generate, parent to new rig.

Hey, thank for taking the time to answer.

I have followed step by step the steps you have mentioned and the rig still does not work. I am getting the same Error message as before: that “Bone heat weighting: failed to find solution to one or more bones”

I have tried different rigs as well. The rigs work on any other file they only seam to break with models imported from zbrush.

I was surprised at your answer so I took another look after sleeping, and I have the same problem now…

The only difference before yesterday and today was I did decimate the mesh yesterday (old computer).

If I decimate first before parenting, it works.
If I do not decimate first, I get the “Bone heat weighting: failed to find solution to one or more bones”.


Edit 1:
There is either:
Something wrong with the mesh fixed by a 0.2 decimate modifier.
The mesh is too heavy for Automatic weight.