Rigging Issue

solved

(ebi) #1

Hi,
I was trying to model a similar thing (worm with teeth) and for some reason, the teeth aren’t in sync with the rig when moved.
I’ve tried to fix the problem but with no luck, so I created a new file and everything worked fine(?!)
it took me quite a few tries to replicate the situation again as I am not sure what I was doing wrong…

to the point
Could anyone help me to fix this rig and make the teeth move with the top bone, just so I can understand what I was going wrong and how to fix it if the same situation occurs again. Thanks, guys will be really appreciated.

and the .blend file rig_issue.blend (680.7 KB)


(helluvamesh) #2

Your problem is that you are using two different methods to bind geometry to bone. The black mesh is skinned (weighted to the bone), the pink mesh is bone parented to the bone. You also need the skin the pink mesh for consistent results.

  • Parent the pink mesh to the armature with “Armature Deform” (CTRL+P)

  • Transfer vertex weights from the black mesh to the pink mesh:
    – select the black mesh
    – select the pink mesh
    – enter weight paint mode
    – 3D View > Toolshelf > Tools > Weight Tools > Transfer Weights
    — operator settings
    ----- Vertex Mapping: Nearest Face Interpolated
    ----- Source Layers Selection: By Name
    ----- Destination Layers Matching: All Layers

Result:
rig_issue_corrected.blend (593.2 KB)


(ebi) #3

Great stuff! :exploding_head:

I did try to use weights at first but I did not know about the ‘Transfer Weights’ tool so it came out off every time.

Amazing! thank you for teaching me that and explaining it so simply.