Rigging problems ! Help appreciated!


I added a rig I’d made in a tutorial to my first Blender sculpt ever! As you can see I’ve lined up all the bones nicely in Edit mode but when I go to Pose or Object Mode…Monster! I don’t understand why this is happening. Shouldn’t edit mode affect permanent changes to the Bone positions, which should then carry through to Pose Mode etc?
Thanks for looking and any help here is much appreciated.

PS i parented the mesh to the armature after positioning in edit mode…

unparent the armature, clear all the vertex groups, then clear the scale on both the armature and the mesh. select either then press ctrl A and select scale from the menu. then do the same for the other. now parent the mesh to the armature again

Make sure the origin points for both objects are on a common centerline. It’s hard to tell from your screenshots, but it looks like the mesh’s origin point is over somewhere near his gall bladder.

Thanks for the reply, K Horseman. You’re right, I’m just not sure how to change the origin point on the mesh…I’ll look into it.

Open the Tool panel (t-key in the 3D viewport). There’s a button that says “Origin” toward the top. Hit that and choose “Origin to Center of Mass”. That should be sufficient for most cases.

You can also specify a location for the origin by snapping your 3d cursor to a particular location and using the “Origin to 3D Cursor” option if you want to place it somewhere particular. Shift-S will snap your 3D cursor to wherever you want, for instance the median point of a selection of vertices in Edit mode, if you prefer to go that route.

Than you Small Troll! Again, I’m not experienced enough yet to know quite what you’re suggesting… I’ll look into it

Okay got it, splendid, thank you!
Not sure what to do next…Small Troll said unparent armature, clear scales…just got to figure out how to do that!

Edit…got it…alt-P to unparent.
Ctrl-A then Scale button

However, still - the correct bone positions, which i created in Edit mode, change when I transfer to Object or Pose mode.

Hmmn…I think the problem is partly maybe that I’ve set the arm bones up wrong in the rig

Select all the bones in Pose Mode. Hit alt-g to clear any location changes, then alt-r to clear any rotation changes. This should return everything to the same positions as they are in Edit Mode. If not, you’ve likely set up some constraints incorrectly.

Thanks. Yes I think I may have set the bones wrongly when I added a shoulder bone.
I returned to different rig that I made in a tutorial and that’s working better, Something strange that keeps happening to my rigs is that the bone names keep changing to the name of the bone one step up the hierarchy… so finger becomes hand, foot becomes lower leg bone. Is that something i’m doing wrong , or a bug?spelling

I have never seen a bug that changes bone names. I suspect you are doing something and not realizing it, such as deleting bones by mistake or something like that. Hard to tell without a more detailed description of the problem and a .blend file. When do they change? What do you do before they change? Is it happening somewhere in specific?