rigid bodies go through moving floor

So I have a floor that is going up and down pretty quick like during an earthquake and I have some cubes falling from the sky. Sometimes the cubes will fail to collide with the floor (which bounces them up on every hit) and go through it to an eternal abyss.
I’m guessing it’s because the floor is going up and down very fast and one frame it’s below a cube and on the next already above it.

How can this be overcome and keep the cubes “above” the floor?

They are passing through because the elevator is moving fast enough that it passes through the rigid body objects between calculation steps. By default there are 60 steps per second, so this is usually good enough since there are usually only 24 frames per second, but if your floor is moving a great distance at speed, you can see just by going through the frames one-by-one that it leaps quite a distance between frames. Increase the steps per second and it should help. By how much, I don’t know. Depends on how fast your floor is moving I suppose. You can find this setting under Rigid Body World in the Scene data tab of your Properties window.

Thank you. I tried setting the value as high as 10,000. It still goes through the floor
BTW, the floor’s z scale is controlled with an audio file, if that will help.

You could post your .blend file so we can find out if it’s happening for some other reason. www.pasteall.org/blend/

Here it is.

I think it may have to do with the fact that you’re animating the z-axis scale of a plane. That seems like an odd choice, since a plane has no z-axis height at all. You might be better off if you apply the object scales on that plane first (ctrl-A in object mode, after removing all the keyframes), and instead using the audio to animate its z-axis location instead of scale. See if that makes a difference. And increase the steps back to maybe 120 or so.

The boxes just went through the floor.
You can test it. Choose any audio file in the Graph Editor->Key->Bake Sounds to F-Curve.