Rigify Bone Rotation Issue

I set up the metarig so the knee bends at the rubber joint at the very top. In the metarig, there was one shin bone that ran from the joint to the bottom of the leg, but when I generated the rig, it split the bone into two pieces. The bottom shin bone is rotated at an angle and it’s deforming my mesh, but I can’t figure out how to turn it straight. I would prefer to just have one bone since my mesh doesn’t bend there but if I can just get it straight that’ll be great. I’ve selected the problem areas. (Note: The cutouts in the middle of the leg, are supposed to be on the sides of the legs.)


You can merge the bones by selecting them and pressing Alt+M. You may have to adjust your weight painting afterwards. As for the other issue, I’d have to see your file.

When I merged the bones, the IK stopped working for the lower leg. I’ve put the pre-merge file if you can look at it. Robot.blend (5.03 MB)

Try this… in pose mode, press Control + A, then Apply Pose as Rest Pose. You may want to put a knee pole target in there to keep the leg from pointing the wrong way, but this should fix the twisting issue.

Do I apply the pose to the entire rig or just one of the shin bones? Also can you explain how to put a knee pole target? Thanks you for your help.

You don’t need anything selected to apply the pose. As for the knee target setup (pole) – it’s a little too complicated to explain briefly here, but there are plenty of tutorials on YouTube and other places that explain it better than I could.

Maybe go back to the start bones check the bone roll on that bone, and generate again. It should be at 0. Also another option is you can simply weight paint around it. Just paint it all to the upper bone and zero out the wights on the lower one. But truthfully it should not have twisted. I would first go back a step and see if you can tell why.

The roll of the bone was off by almost 90 degrees. It fixed the issue of the mesh twisting. A knee target will fix the issue of the leg bending backwards but I haven’t messed with the weight painting.

I found this that may help – it’s for the elbow but could be applied to the knee as well. I didn’t create this tutorial (I just organized it into a PDF from a web page), but I can’t remember who did, so don’t try to sell it or anything :slight_smile:


_IK__setup.pdf (201 KB)

Cool. For the knee bend, basically, you want to prebend the knee a little. And the bone. This is standard practice to give IK an inclination as to which way is correct. So it will start bending the right way. The pole vector can help of course. But that is not the purpose. The pole vector is to orient the knee. Since you are using IK you can not start to orient the leg at the hips like you would with FK. The pole vector is your orient control on an IK chain. That is primarily what it is there for.

Regarding the painting. Keep in mind that the reason the bones are split is for organic characters. It is prevent all of the twisting from happening at the wrists and ankles. However if you have a mechanical character you would have joints there. Not flesh. So you might want to paint out those twist bones. Otherwise your metal will twist.

For no extra bones look in the meta-rig before generating:

With meta-rig in pose mode select upper leg and upper arm bones and set limb segments to 1. Bbone segments are set here too. Without the extra bones the bendy joint tweakers don’t work but Bbone (easing) settings in its panel will if you need them. For robot type rigs I set bbone segments to 1.

default rigify leg options

default rigify arm options

These IK legs seem a lot more backwards twitchy than I remember. As mentioned above a good knee bend on the metarig helps.

This rig uses thigh bone rotation instead of pole targets (those big arrow controls at top of legs). After testing for a few minutes it looks like pole targets are much better to counter the backwards bend issue. Well, for posing. I didn’t test animating the thing. These legs seem much more backwards prone than I remember. Maybe because of the IK stretchy parts. I’ll have to investigate this further.

One more thing while we’re here. The latest rigify default selects tentacle fingers (auto curls finger when “knuckle” bone rotated). In pose mode select top finger and thumb bones, delete Rig type for dropdown menu to appear and select limbs.super.finger (finger control curls fingers when scaled not when rotated).

Rig type selection for fingers and thumb.

Btw set the transformation orientation to Normal if using the widget for posing. Default (global) scales wrong axis on finger curl control. Also good to stay consistent (red axis = x axis = the axis normally used to bend joints).

Hope this helps next time if not this time.

Edit: Good grief why are these pics blown up so big? Originals are small. Edit 2: Oh it’s because I have to zoom this itty bitty site 170% in my browser. I am so looking forward to the discourse site. Hopefully it will be responsive.


Yeah. Good find. I figured there was a place to turn those extra bones off. :slight_smile:

Yeah an often overlooked critical feature hiding on certain meta-rig bones in pose mode. Makes sense if one knows how Rigify does its magic but a pitfall for the uninformed. Learning the pitfalls is part of the fun but this is a bad one hiding in the weeds. There’s many incomplete Rigify tutorials / demos out there.

Thanks for the reply.


Yep. So much we learn comes from digging in, unfortunately. So thanks for all of these great tips. :slight_smile: