Rigify Rigging Deform Bones messed up

I was rigging a MakeHuman mesh with Rigify when I ran into an insurmountable skinning problem. I created the meta rig, generated the rig, but the deform bones were not placed properly so when I tried to skin the character mesh, most of it disappeared. I started again with nothing but a rigify rig, and here is what happens:

As you can see, all the deform bones are where they are supposed to be, in EDIT mode. But when I switch to Object mode (which I would have to do to parent a mesh to this armature, most of the bones dissapear.

This is the rig in object mode (looks much the same in pose mode.) I have all the layers turned off except for the deform bones, but the rest of the layers look like they are supposed to look: bone shapes, mostly. At any rate, I am running Blender 2.68a and it has Rigify addon version 0.4

How can I fix this?

I’ve had a similar problem yesterday when opening an old rigify rig in blender 2.68. The solution was to make sure the checkbox “trusted source” is checked in the “open file” window.
Looks like you start from scratch, so won’t be the same problem, but could be linked.

Thank you. I checked the ‘trusted source’ box before I opened the earlier blend file (before I generated the rig from the metarig) and when I generated a new rig, all the bones were in their proper places.

I had no idea that ‘trusted source’ checkbox was even down there. It does not seem to stay checked, either. And I couldn’t find an option to ‘always load from trusted source’ in user preferences file tab (which is the logical place to put it) or in any of the other tabs.

Thanks again.

User Preferences > File > Auto Execution: Auto Run Python Scripts (checkbox)