rotating around an active vertex in edit mode


Just wondering if there’s a way to rotate the view around a selected vertex or group of vertices. If not is there a work-around for this? At the moment, my model swings off screen everytime I rotate the view.

Shift_s > Cursor to Selection
Press [C] (Center view to Cursor)

I tried that, and it does centre the selected vertex within viewport but, as soon as I rotate the view, it revolves around the object centre instead of the selected vertex. The only work-around I can think of is to move the object centre, but that would be a real hassle.

Any other ideas?

The only other thread I have found relating to this issue is over at:

I found a work-around there, which is to rotate using the number pad instead of the middle mouse button. Being able to use the middle mouse button as usual would be more natural and preferable in my opinion.

Does anyone else find this interrupts their ‘intuitive’ modelling pleasure? As in, rotate a bit - tweak - rotate a bit more - tweak

I am using v2.42

Have you changed any of the Default settings in the Information Window:: View and Controls :: View Rotation section? For instance; turning on ‘Around Active’ would do what you are describing. In that section, [Trackball] is the only option activated. What’s your settings?

All you need to do is turn OFF ‘Around Active’ in the user preferences. I should have read the other thread better… sorry!

Ah cool, well problem solved.
I wasn’t really aware of that feature, so now I know it’s there if I ever need it. :slight_smile:
I guess the downside is more things to go wrong or have set the wrong way
for what you’re doing at a certain time. The ‘Move Object Centers Only’ is another option
that can make you wonder why things aren’t rotating like normal :wink:

there is a easier way i think, hit “,” in the numpad and voila.

that’s right greboide however with that method the camera zooms in to that area. not always what you want.