Rotation axis inverted when animating

I have this problem but with only one character, when i try to move his head (bone) from up to down it moves from left to right and vice versa. Same if i move any other bone.
Do you have any idea why this could happend?

Sometimes it feels like tiresome to post the same thing again and again but people should understand that we don’t all pick up stuff from the same place. I should tell you this:

Cucumihai if you want answer to your problem please give us more details for example post some screenshot of your scene set up, .blend
In the description you gave, so many things ca be wrong, It might that you did mess up your constraint, or your bone axes are pointed into different direction, … Please us to help you. :slight_smile:

Thanks for replying :slight_smile:
The problem is simple, when i try to move my character’s head up and down it turns left or right, so my X axis is actually the Z axis and vice versa.
I should note (i just realised this) that the same character works on my desktop pc, this problem is only with the Blender on my laptop, also, it does the same with every other object or character (that on my desktop pc works fine), so i concluded from this that my problem is something with the interface, maybe I pressed something wrong.
It doesn’t matter if it’s global position or local and i also tried to change the bones rotation in the transform tab but that did nothing as well (strange if it did since it’s happening with all the objects).

The screenshot doesn’t tell much can you post a .blend file?

That’s irelevant, because it’s something wrong with my settings. I made a test and created a new project and tried to rotate the cube but it does the same, i moved the same project on my desktop and it’s working fine so it’s a local problem.
It’s really strange and i badly need a fix.
Is there a way axis can be reset or something like that?

Try to Load Factory settings and save setting as Default. Do like this:

step 1: File -> Load Factory settings
step 2: File -> user preferences -> Save As Default. You will have Blender default settings. I hope this helps.

I still believe that if you save a blend and send to some one the person receiving your blend file will open it with you settings. I might be wrong.

I did that and also reinstalled Blender and nothing, i think it may be a problem with the drivers but they’re all up to date and Maya for example is working just fine.
I made some tests with my other computer sending files back and forth, i tested the default project (the cube when you start a project) on my laptop(lenovo g580) then the same save on my desktop and it’s working fine on my desktop.
Such a strange problem and i need a fix for it badly because i have some deadlines coming and this puts a hold on my project.
Thanks for trying to help me and if you have any other suggestions please tell.

May be should to irc to discuss with some devs.

Here’s some routine questions and troubleshooting steps I would try. Of course this could all turn out to be nothing to do with the issue but you never know with these blasted computers, especially when it’s related to a beast like Blender.

The first question is does this happen when you rotate with shortcuts instead of the 3D manipulator widget?

Did this issue come out of nowhere (did it used to work correctly)? If it used to work has anything changed along the way like a driver update? Latest video driver and working in Maya doesn’t mean it’s not a problem with Blender.

First I’d try different settings in Blender Userprefs > System > OpenGL especially Window Draw Method. Manipulator settings in Userprefs > Interface is another thing to try, especially the hotspot setting if this is a manipulator problem. This is a long-shot but I’d try these things first because they are the easiest to eliminate as the cause of the problem.

Next I’d look into the video card settings. Some global settings like anti-aliasing can screw up Blender. So I’d try different settings in there. This is another long shot but this is a process of elimination game at this point. You can’t figure out what the problem is but you can at least figure out what the problem isn’t.

The video driver is the next thing I’d look into. If it used to work but now it doesn’t and the driver has been recently updated then that’s a big clue there. Do you auto-update? If it’s a new driver I’d revert back to older. Of course this all depends on whether Blender ever worked correctly on this computer, and I’d at least take some time to search around and see if any similar issues with said driver have been posted anywhere online.

This is just some troubleshooting steps to try, and another bump for the thread here if nothing else. Unusual symptoms like this sounds like a video/opengl issue to me. The first step I used to take was turn off all video acceleration to take the video card out of the equation. It makes Blender use software only for the openGL display. Unfortunately that was doable in winXP but I don’t think that can be done anymore since that OS version, at least not with NVidia. Maybe you can do this in your system.

erickBlender’s advice is all I would know to do if nothing I mentioned worked, although it’s a pain if you know nothing about irc. Reporting this as a bug may get you info or advice too.

Good luck.

Welcome to BA forums.


Thanks for your ideas.
I changed all the settings you mentioned but with no luck.

I have to mention these:

  • this only happens when i rotate with manipulators, the transform or scale tools work great. When i rotate by shortcuts works also, the manipulators are the problem i see.
  • this issue existed from the first time i installed Blender on this laptop.
  • I didn’t mess with drivers after i installed Blender.
  • I have default settings in Blender.
  • I have Intel HD graphics 4000 as a video card in this laptop (i don’t know if this is a problem)

You can see in this picture (with default settings) that when i switch to the rotate tool, the axis aren’t aligned.

Hmmm. Actually I can’t see that in your picture… The axes align perfectly:

The half-circles on the widget correspond to their respective axes: Blue to rotate around z, red ro rotate around x and green to rotate around y. Whatever your problem is, it is not the axes’ alignment…

I missed that! It’s funny how I manage to read the text and for some reason totally ignore an inserted pic.

I’m under the impression grabbing an axis rot handle spins the object on a different axis is the symptom. Bones and cubes both. Seems like this isn’t the only time I’ve seen these symptoms mentioned in BA forums.

No matter, all the info I posted is good advice for anyone experiencing any sort of strange display/mousing issues.


Yes, I thought so, too. Until the OP posted that image, indicating some kind of misunderstanding about the functionality of the rotate manipulator… Well, I hope he finds a solution!

Oh, i thought the rotate axis is showing wrong because the colors don’t match, anyway, the problem is the same offcourse (don’t pay attention to the pic)

Yes, the problem is: when i grab an axis handle of any object in any mode the object spins around a different axis. OTher tools work, only the rotate one is broken.

I tried to explain as best as i could but english is not my first language so, sorry for any mistakes.

FINALLY. I have found the devil -----> My graphics card driver.
I removed it and all seems to be fine in Blender, i have to run some tests to see if i can run without the driver in other applications.

So, If future Blender users have the same problem and you have an integrated graphics card, change or remove it.
Thanks you all for trying to help me.