Scale along normals

Hi, I created a simple tube, rotated it and now want to extrude a part along its normals. I extrude, hit RMB to cancel and then scale while hitting SHIFT-Z to constrain along the XY axis. However, the Z-axis constraint seems to be the global one which is completely useless, as I want to scale along the normals.

How would I do that?

Many thanks!

Attachments


Next to the tab that changes between modes, next to the little hand, there is Global written. Change that to normal. Then select the things you want, and press S. Then press the axis you want to use two times, i.e., to scale in the normal x, press ‘X’ two times.

Thanks for your quick reply. I tried that and it works. The only problem that still remains is: My XYZ axis of the normals don’t seem to be adjusted correctly and I have no idea why.

How would I fix this?

Attachments


Post your .blend so we can take a look at it.

It seems like once you’ve scaled it up, the normals change and you can’t readjust it anymore. I specifically tried to re-scale it pressing SHIFT+Z twice. Please find attached the .blend file.

Thanks again.

Attachments

tube.blend (354 KB)

In Object mode Ctrl-A -> set scale and rotation. This usually fixes the normals when they go pear-shaped, though I don’t know why.

Hmm… tried that and it didn’t fix the problem. When I go back into edit mode, they are still not aligned in the way you would expect. :confused:

Attachments


Try to select whatever you are trying to scale and press Alt + S, which is scale along faces normals.

To my surprise, ALT+S seems to use the same underlying algorithm. In the file I posted earlier I can’t seem to get it working, not even with ALT+S…

Attachments

tube.blend (313 KB)


You could create a new Transform Orientation which you can use for your scaling.

In the example just scale the top ring with S and twice Shift Z.

The new Transform Orientation was created by selecting the top edge loop, press Ctrl+Alt+Spacebar or press ‘create’ under the Transform Orientations tab in properties (‘N’).

Attachments

tube2.blend (230 KB)

Ok, I see where you are coming from and it seem to work. However, when I tried to do the same procedure for the middle ring, I couldn’t get it to work. It would not recalculate the normals. I guess the only workaround then would be to use another object

Also, I’m starting to get the impression, that this is actually a bug. I mean, shouldn’t you be able to quickly access the normals when you select the faces and keep on modeling??

Anyway, many thanks for your help. If anyone knows what’s going on or why it doesn’t work, please enlighten the rest of us.

Hmm… the same seems to be the case with Blender 2.49…

Select what you want to scale, snap the 3d cursor to selection, set Transform Orientation to Normal, S to scale, hold down Shift and press Z twice. It works like a charm.

Forgot one thing, set pivot to 3d cursor.