Scale object without scaling the parent

Here as shown, I am designing a roof folding animation, once make the led holder stick parent with roof cloth, stick follows roof cloth well but unexpectedly get scaled with it together. How can I only let it follow cloth but disable scale?

I tried the constrain (Child of), could not get the expected result. Please help0166-0225_1

1 Like

you can use a copy scale constraint on the childs, constrainted by the parent in world space and power at 0

If you are using an armature, you can disable the inherit scale in “Relations” properties of the child bone


I would not use parenting for this scene at all. I wound just use a cloth simulation with the pin vertex groups following the animation of the led lines. I believe the effect would be more interesting, since in your model the cloth is not physically believable.

Thanks for your reply. I am not so familiar with cloth modifier, could you explain little more how it can be done more realistic via cloth modifier?? thanks

One minute.

1 Like

thanks, waiting…

Firstly I’ve created the geometry for the led holder sticks, as you call them. Then I made a plan with some loop cuts that I aligned to the sides of the sticks. These cuts will be later the pin vertex groups I will create to hold the cloth where it needs to be hold.

After that we need to subdivide that plan to give us geometry enough to use the cloth simulation.

This is the first part. As I progress in what I am doing I will edit this comment to add what is done so far.

Added some loop cuts, 10 between each stick and 20 over the length of the cloth.

1 Like

great, thanks. following your progress to apply same for mine. also you can upload the final blend file if it’s no problem for you

No problem at all.

I’ve created the vertex group called pin and assigned to the selected vertices with a weight of 1.

Now we are ready for our first step of cloth simulation.

Applied the cloth simulation with the default settings, only went to “shape” and selected “pin” as our pin group with the “stiffness” at 1. Played the simulation a bit and we have already the fall from our cloth.

Then I added shape keys for the shape of the cloth, animating the first line of cloth and also for the sticks that I kept in a single mesh to make it easier to animate using the shape keys.

New level, new shape keys. Need to be careful with the values, keyframes and modifications each shape key gives to the animation.

The blend file where you can see the animation. cloth sticks.blend (3.9 MB)

I hope you like the effect.

1 Like

I will check, endless thanks for your great effort!

1 Like

You are welcome. I’ve made a mistake saving the file. I did save it after playing the animation and the file now has something about 3.9 M. I did save it again in the frame 0 and it has now 162 KB since it has not baked animation in it, I suppose.

Anyway, bot have exactly the same content. By the way, if you need some hint on the issue, just send me a message.

1 Like

thanks a lot. the time is quite late at my location though tomorrow I will look up deeply and notify you if need any help. Thanks again

1 Like