scaling issue

Not sure what i’m doing wrong.

I have a selection of faces that I have extruded in,I now want to scale those individual extrusions (so they look like what I have drawn in red)

but I can’t seem to do it,it treats the faces as a whole object and won’t scale them individually.I’ve tried the different pivots but no luck.

(this is something I can do without hassle in maya)

so i’m basically trying to scale each of those faces so that I can create a kind of V shape,as I have drawn in red.

anyone can help? :spin:

http://www.nubiangreene.com/images/scaleface.jpg

Did u try alt+S yet ?

I have tried alt+s but it scales weird,I want the faces to retain there rectangular shape,but instead they get weird dips in the center.

http://www.nubiangreene.com/images/scaleface2.jpg

again when I do this in maya,its a non-issue,so i’m not sure if i’m doing something wrong,or its just blender,and I have to find a work around.

Create an array around an empty. Select 1 tooth, fix it to your hearts desire, then array duplicates in a circle. Or spin tool will work.

There is a way. After you extrude, with the faces still selected hit F to make the quads ngons, change the pivot to individual origins and scale the faces as you like(to get that Vshape). After scalling, hit Ctrl+T to triangulate the ngons and Alt+J to make them quads again. Good luck!

edit : looks like lordseeker beat me to it while i was uploading pictures :smiley: with less clicks for the faces rebuilding.

Yes, it looks like it’s indeed all about workarounds for such case.

Here’s another workaround along the previous suggestions :

-select the faces in Face selection mode
http://i.imgur.com/rfRDI.jpg

-set the pivot mode to “Individual”
http://i.imgur.com/0m0KP.jpg

now if you scale from there as you probably noticed, it will do something really bad by distorting the faces, to avoid that :

-press X -> Dissolve to make those faces into ngons
http://i.imgur.com/nZGlh.jpg

-press S and scale as you need
http://i.imgur.com/YL75S.jpg

-once done, in Vertice select mode, select the central vertice up and down of each faces and press J to join them to rebuild the original faces
http://i.imgur.com/H2GBU.jpg

Would be good if there was a tool that didn’t required workarounds, but it looks like there’s none.

you could also use the multi extrude addon
should be easier to do !

http://wiki.blender.org/index.php/Extensions:2.6/Py/Scripts/Modeling/Multi_Extrude

salut

lordseek + sanctuary ,this worked,never knew about those shortcuts until now!

but I had to switch to face mode instead of vertex mode for the scaling to work,which is strange.You have all been a massive help.

the mode switching is a bit of a bummer though (face mode + individual origins)

fred,i had considered the array method,but still wanted to solve this issue.

ricky i’ll look into this addon,it looks great.

is there a shortcut to toggle pivot mode guys?

There is an easier way with a two step scaling process (while in face selection mode, right after pressing “E-KEY” to extrude, and then “ENTER-KEY” to set the extruded faces):

  1. while scaling with the “S-Key,” press “Z-Key”
  2. scale again with the “S-Key,” this time using “SHIFT-Z”

A single shortcut no, well I’m not aware of any…but you have them like this:
-pivot around 3D cursor- " . " (dot key)
-pivot around bounding box center- " , " (comma key)
-pivot around each object’s own origin- "Ctrl . " (Ctrl+ dot)
-pivot around median point- "Ctrl , " (Ctrl+ comma)
-pivot around active object- "Alt . " (Alt+ dot)

maybe I’m missing something,but it sounds like you described the way to normally scale anything? lol. this method didn’t work which is why I posted this thread.

blender seems to have weird behavior when scaling multiple faces at once,even with pivot individual faces on its doesn’t behave as expected.

For instance,lets say i’m making a gear.Which is pretty much the same as what i’ve posted,in reverse.

i’ve got a cylinder with 12 divisions,i’ve selected every other face (6 faces) I extrude those faces out,now I want scale each face to get my gear “tooth” shape.So I want to scale each face in x to make the faces thinner (longer height than width).I only want to scale those faces,without effecting the length (depth) of the extrusion i’ve pulled out.

and,its impossible! without doing each one individually…lol even with individual origin selected.

heres a screenshot,with a paint-over of what I want.

http://www.nubiangreene.com/images/simp.jpg

(don’t worry about the top faces,I just knife tooled some edges in so the top wasn’t an n-gon.)

i’ve tried the method you guys suggested above,and I can’t get it to work,in maya I can do this in 4 seconds.Again i’m not sure if this is a limitation in blender,or a bug with the pivots.

I’m convinced i’m doing something wrong,because its something that should be so simple…

edit: i’ll have to try this multiple extrusion addon tomorrow.

Sorry, ng-material. I see what you are doing now, and I agree, it should be a lot easier in Blender than it is. I would add an empty, rotate it, model a single tooth, add an array modifer with object offset set to the empty.

no need to apologize :slight_smile: the entire post wasn’t directed at you :slight_smile: I’m just trying to present a case,to help people understand,and discover limitations of blender.

I can use the array for sure,but this doesn’t eliminate the problem for all cases,like if I wanted extrude some spikes out of a sphere for instance (like a mace weapon) ,can’t use array for that,or at least,you shouldn’t have too.

so should I assume that this is just a limitation with blender?

Surely I can’t be the first to mention this issue? haha that’s why I’m convinced that I’m doing something wrong

Try this

Select the faces you want to extrude :
http://i.imgur.com/47jYq.jpg

press ALT + E -> Extrude Individual Faces
http://i.imgur.com/qlR99.jpg

Set the pivot to “Individual Origin”
http://i.imgur.com/0m0KP.jpg

Press S to scale then press SHIFT + Z (to exclude the Z axis on the scaling, the axis you want to exclude may be different depending on the orientation of your model of course)
http://i.imgur.com/S0eox.jpg

For a mace pointy things :slight_smile: if you don’t want to use dupliface, it should work the same if your extrudes are only 1 faces :
select the face to extrude - > press ALT+E -> Individual Faces , change pivot to “Individual origins” and press S to scale

Now if your pointy things extrude are made of more than 1 face individually, , you may need one of the previous workaround (the ngon one should be the easiest i think) to make it work, probably not a limitation of Blender but it’s more a tool that is unfortunately lacking from Blender toolset.

did you try multu extrudfe which is espacially made for working with N faces!

also if you need a gear there are 2 scripts included in blender for making gears!

salutations

this worked,I had tried constraining the axis before,but it didn’t work,perhaps its because I didn’t extrude individual?

rickyblender,I tried to download the addon,but firefox says the link is untrusted?

i’m not actually making anything,i’m just testing blenders modelling functionality at the moment.

If you installed the contrib addon bundle to the stable version of Blender or downloaded Blender from the buildbot (it include the up to date contrib addons too) , in the File -> User Preferences -> Addons , enable “Testing” and in the “Mesh” category enabled “Mesh : Extra Tools”.
Extra Tools is a compilation of several usefull old addons in a single tab

It will add a tab on the toolshelf in Edit Mode : “Extra Tools” , one of the function is the multi face extrude addon.
Though it’s nice to use (especially with the rotations etc…) i don’t see how to extrude without the faces separating.
Can you explain how you would extrude like this Ricky with using this addon ?
http://i.imgur.com/rfRDI.jpg

sorry i used this mulextru a few week ago
and since that time i have a bug in windows and cannot get to this mextur script
dont’ know why have to check on bug report to see what happen to this problem

but why do you need here to split faces for the gear?
and why not use the gear script would be much easier !

multiextr should do it as in post 14
and even more options in tool panel!

note: be back later on this afternoon !

salutations

you don’t need to have splits there for a gear,but the point is,the tools should work as expected,regardless.

i’ll go ahead and get these addons installed…

edit: haven’t used it as properly yet,but the addon is really excellent.

got 53235 today

and i delted the matlib addon to remove the error!

and i can get the mesh extra tool in the mesh add menu

but in edit mode i cannot get the mulextrude script !

not certain what is happening here!

i can upload the script in the text editor and run it from there then i get it in the tool panel!

seems there is still a bug on window 32 bits !
have to report this in the bug report !

hope it works for you !

thanks