Scene not displayed in runtime, 2.61

Hello folks,

I have encountered a strange phenomenon today as I tried to convert weeks of work into runtime. The main scene does not appear at all while the overlay displays properly. The game itself runs without errors (there are sounds, overlay scene updates as it should, etc), it just does not appear at all.

For the record:

  • Blender 2.61, in other versions the game simply does not run as it should
  • Other games with overlay scenes work fine in runtime, same Blender version
  • Other scenes in this same game display without fail
  • The main scene appears black even if the world colour is set different, so not even the world appears

Within Blender as it is supposed to look:

As an .exe:

Any help appreciated!

Are you sure your 3D window is set to textured and on the side panel you have GLSH/multitexture/singletexture as you should?

How does it draw the scene in wireframe, is all the geometry there so you can narrow the problem to material/textures/lighting?

EDIT: Very nice and fresh looking game :slight_smile:

Render settings are set the same for all scenes, even the overlay scene. All scenes use the same materials and other scenes just work fine. All the scripts run without error (checked the console window), so there should be at least the mist appearing, since I set it kinda randomised via python.

Also now I tried other versions: 2.60 runtime errors and closes, 2.63 has the same display issue.

So does the runtime print errors? You can check by starting the .exe via command line. Even if scripts run fine in .blend the runtime can have all kinds of stuff such as missing files if you change working directory etc. and haven’t packed them.

Do you feel comfortable sharing the .blend? I could at least test it’s not your PC only.

It turned out that it has to do something with parenting and clipping distances. After rearranging the parenting system of the camera and setting the camera near clipping distance above 1.0 the problem has partially gone.

Partially, because looking straight down, part of the screen still stays black where the camera’s parent, an invisible cube is. But the blacked out area is bigger than the cube itself. Weird problem, but if everything else fails, I try and cover it up somehow.

Could it be you have same scales on the parents?