scipts not working

I am having problems with the following scripts:
espresso…after following all instructions to the hilt…it still says 'python script erroor.check console.
geodesic dome: same as above.
BMAE v1.1 se: same as above.
can anyone with similar problems solved help out?

BMAE is at version 1.2 and works with 2.45 as far as I know. I updated it some time ago but never made mention of the update.

If you are referring to Geodesic v1.4 by Andy Houston (2002 - 2005), with a cursory test it performed, saved and loaded fine for me. I can’t speak for Espresso though.

Also, you’ll get a better response here if you describe the reason/type of error output to the console.

Espresso is not working with current Blender versions.
Last working version of Espresso was v1.2 working with Blender 2.42. Then - with blender 2.43 the script broke due to python api changes. For this reason i took Espresso offline.
I can’t remember what the problem was… Maybe there will be an Espresso v1.3 in the future. I have a messy (but somehow still working) new version in development. Unfortunately, the same things seem to be going on in current SVN blender versions. Api functions change behaviour - currently it’s the boundingbox that gives me headaches. In some Blender compilations the boundingbox is in global coordinates in other versions it seems to be in local coordinates, there seems to be a difference between linux and windows, …
So - i can’t promise anything.


hi, Geodesic 1.4 is fine, Geodesic 2.0, I use a custom version…
open geodesic2.0.blend
do not run the script. (although I do, but ? already fixed)
Open the text editor.
save the files
to the scripts/bpymodules folder

Add a header to the file as following…
Name: ‘geodesic2’
Blender: 241
Group: ‘Wizards’
Tip: ‘Create geo objects
above the
#Hit alt-p to start
Rename the modified file to
so you know what the script is more than anything.
save this file to the blender/scripts directory.
you now have a fully working version of Geodesic Domes 2.0
appearing in your Wizards scripts menu in Blender.
don’t forget to press Update Menus in the scripts browser.
hope this helps.

edit, I cannot confirm the script not working, as it is standard for me to install this script.
so if you are getting a error please post.

thanx 4 the tips…will try them out and get back 2 u. btw what can b used in place of espresso and where can i download the geodesic dome script. thanx again.
check here for a listing of scripts.
browse for locations.

m-a,thanx your help worked. geodesic 1.4 works fine and 2.0 too. But how do i isolate the different .py in the 2.0 script or do i save the whole text into different .py? i am a total noobie in both departments…modelling & scripting.

… btw what can b used in place of espresso…

Blender’s sculptmode

can anyone help me with fixing up the BMAE 1.2 script and the geodesic 2.0 script isolating…i.e saving the same as different .pys?

open geodesic2.blend.
by default the text editor is open.
add the header to the first file
in the text editor, press file, then save as,
save new text file to blender/scripts.
back in the text editor, press the text name window, then open 1 by 1 the rest of the text files & save as with their original names to bpymodules.
close geodesic2.blend without saving. (so as not to change the original file)
open blender to have geodesic dome 2 working from the scripts wizards menu.

thanx m-a,
will do as u say and let u know…as far as i could c that there was only one text file in the geodesic 2 blend…and so was confused as 2 whether the parts of the main text files are supposed to saved differently!!! got any idea as 2 what could be wrong with the BMAE SCRIPT…i get: syntax error:from-future-imports must occur at the beginning of the file.

Sounds like you are using v1.1. That error is referring to “from future import division” located under the script header in v1.1, which used to not be a problem. As of v1.2 it was moved to the top of the MMC module and should avoid that error. You can get v1.2 at geneome in the files section.

Quick install:
Remove any of the old BMAE files from your scripts directory first (just to be sure). Unzip the new version and migrate to the BMAE v1.2/BMAE Files folder. You should have 2 items in there: and a BMAE folder. Paste/move both of them to your scripts folder. Feel free to PM me if you have anymore problems.

thanx o6a & m-a,
the geodesic 2.0 has started working and i have downloaded bmae1.2 and will test it today. thanx again.