Scrape brush no longer real scrape brush in 2.8x?

Howdy blender wizards!

I’m in a bit of a pickle! I have used Blender for years for 3D scan cleanup, but I’m having trouble migrating to 2.8x. My two main brushes are scrape and flatten, which help me remove hair, stubble and noise mainly. In 2.79b I get very smooth surface geometry without altering the overall shape or structure of the face. The scrape brush tends to take the tops off of the stubble and leaves the surrounding geo untouched. The flatten brush usually finishes it off by removing the final noise and smoothing out the surface regardless of its underlying topology.

However, with 2.8x it is entirely different and I haven’t been able to use the brushes. I created a quick video of the process and the problem. I start in the old version of blender where you can see me take out stubble and other skin problems. After that I flatten it out slightly and I end op with the person’s skin without any noise and stubble. However, when I jump to Blender 2.8 I cannot seem to take out just the stubble. In fact, I find that mostly the surrounding geometry is affected and not so much the peak I’m trying to get rid of. The flatten brush seems to just make the surface lumpier rather than flat (it gets worse the longer I try to flatten it). In both versions I’m working with the default settings and the brushes aren’t inverted.

That was on something I’d actually work on. Here is a very basic example of what I mean. In 2.79 I can keep sculpting and the plane will get flatter and flatter, or basically won’t change at all at some point. In 2.8x it will keep getting pushed further and further away.

Thanks, Jan

In Blender 2.82 Scrape brush settings, there is
Advanced // Original Normal

Could it be useful?

It is absolutely useful in the “simple” scenario. As long as I don’t start sculpting on the “peak” area it works out just fine, so thank you! I can’t test it out on the face scan at the moment as I’m in the middle of something else, but I will try that asap.


Hi again,

I think you are right. This does not solve your issue, because sculpt plane alignment is fixed that way. Thought about it this night.

Your issue might relate to the way new blender calculates normal for sculpt plane.
2.8x does use ‘normal radius’, defaults to 0.5

If you use large area to calculate normal for sculpt plane,many surface normals are used and averaged. Noisy normals of random surface are averaged out.

You try to paint with a small brush on a random surface with ‘normal radius’ set to 0.5 … Blender might not use enough surface normals to average out ‘noise’. Scrape brush will dig holes into surface of your scultping.

A larger value for ‘normal radius’ (like 2.0) could do better job for small brush.

Mh … there is an easy way to see it in action. :slight_smile:

I tried a scrape brush with brush radius 150px. With it I hovered over random surface. In 2.8x, blenders sculpting cursor does reveal sculpt plane.

I tried different ‘normal radius’ values, from 0.01 to 1.0 and hovered sculpting cursor over random surface. (Without drawing a single stroke)

With ‘normal radius’ == 0.01 I hovered over different areas (without actually sculpting). Sculpt cursor reveals how sculpt plane directions changes randomly.

I get very different result with ‘normal radius’ == 1.0
… sculpt plane direction changes are much smoother and much more controlled.

I am going to test this today. It does seem like setting the normal radius to 1 leaves the underlying geometry alone and only seems to affect the peaks. At least that’s the result when using those simple test surfaces.

Damn i want the flatten and scrape brush like before but in the new versions…

Just checked them both. I wasnt a big fan of flatten in 2.79, i used scrape brush for flatteling planes so i used scrape a lot. In 2.92 if feels even more predictible, so maybe its a matter of settings.

I have since gotten used to the new brushes. The main thing was the normal radius. Older versions didn’t have this to my knowledge and their default setting was probably 1.0 or higher whereas with the newer versions it starts at 0.5. This totally threw me off but I’m all good now :slight_smile: Blender still rocks!

1 Like