seamless smoke animation


(Tullisti) #1

is there a way to make the end frame of an animation the same as teh first frame, so that when the animation is repeatedly played, there are no jumps or glitches??

thanks


(S68) #2

???

You must do this by defining your animation so that in last frame everything is in the same position/state than in the first…

Of course you must then drop that last frame otherwise, when you’ll cycle your animation you’ll get two identical frames one after the other, and this is a glitch in itself.

Stefano


(Tullisti) #3

sorry, i should have added the fact that i am using a particle system to generate some smoke. basically, the animation is smoke coming out of a chimney, and i want to use it in a game, but at the moment it glitches after the 10 second long animation.

thanks. :stuck_out_tongue:


(Alltaken) #4

hmm i didn’t think particles worked in the game engine.

if it is to be rendered then added onto a flat mesh as an animated texture then i have one sugestion.

render out the 10 seconds.

then reverse the order of the frames in a movie editing progam (or save as individual frames and rename them in reverse order manually (i think you can select all and do a rename function somhow easily).

put scene one and the movie(or individual frames )into the sequencer

using the sequencer do a cross fade for the entire length of the animation.
droping the last frame as S68 said.

perhaps this will work or perhaps not but it is just a sugestion working on intuition. (thinking about it this may look like smoke is going back into the chimney) hmmmmmmmmmm bugger

hope it works (no harm in trying) :smiley: :smiley: :smiley: :smiley: :smiley:

----------------this one will work---------------------
another idea is to duplicate the particle emiter and reduces the number of frames each lasts for then put them in sequence eg 5 frames out of phase or somthing then when it gets to the last frame it will be starting a sequence agin therefore seamless. (put a copy of an emitter an equal time before the start of the animation )



eureka i tried it and found the answer for you .

duplicate your emitter. (asuming you are using 25 frames per second for a 10 second animation)

make the new emitter start and finish 10sec/250 frames before the other one eg if it starts on frame 1 and fishes on frame 500, make the new one start on frame -251 and finish on frame 250.

here is the test animation i did and it took a few minutes to whip up.
2 seconds long encoded with divx5.0.2

http://www.dm7.net/albums/album07/snoke.avi

its a tiny file so download it

sorry about the mess of this post (i like to have people see how i come up with my solutions and that i thought about it on the spot.)

he he he have fun. :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley:


(RipSting) #5

Don’t use blender for creating seamless particle animations unless you need them to be integrated into a larger animation.

Download the shareware version of Infinite-textures at www.i-tex.de

Using the shareware version you can create up to 255x255 images without watermarking. This is the best texture generation (creation) package out there!!! PLUS it has a particle engine that creates seamless animations!

Check it out


(Tullisti) #6

thanks guys :slight_smile:

just to clear things up, I’m nit making the game using blenders game engine, but rather creating all the 3d models in blender, and then adding them to the engine from there :slight_smile:

I’ll try all the above suggestions, thanks !! :stuck_out_tongue: :wink: :smiley:


(Tullisti) #7

I’m having trouble implimenting this, could i ask you to email me the .blend file? or post it online?

thanks :wink:


(Alltaken) #8

sure.

i will do it now but it will be a new one cause i didn’t save the last.

:smiley: :smiley:


(Alltaken) #9

here is the file you wanted.

note rename it .BLEND as the site i am uploading to does not allow files that are not images or movies so i cheated and renamed it smoke.avi when it is really smoke.blend

http://www.dm7.net/albums/album07/smoke.avi

ok i did this animation for 50 frames. (1>50)

make sure the particle life is set to the length of the animatin (in this case 50)

make sure there is one particle emiter that lasts for the entire length of the animation (in this case 1>50)

make sure the other emitter is set too end on the same frame the other starts and last in total the same number of frames as the first one (in this case -49 >1)

if you look at the animation options you will see that everything except the sart and end frames is the same.

hope that helps

remember change the file extention to .blend :smiley: :smiley: :smiley: :smiley: :smiley: