Seams in the same texture between two objects

Hi. I’m new to creating UVs (I’ll cover the basics). Faced such a problem:
I have two separate objects that represent a single model. After creating a sweep, there are seams between them, which are clearly visible on the heterogeneous texture, and they also have different texel densities. The question is how can this problem be solved?

Did you look if one of your objects is not mirrored in the mapping process? Are they really in the right proportions on the UV mapping and their positions are right there?

1 Like

@M-777 , look here is someone who needs to use the technique we were talking about. Maybe you both could charge some impressions too.

2 Likes

I don’t know if I understand correctly, correct me if I’m talking nonsense. The problem might be that you should assign each mesh its own material, based on the seams?

1 Like

I don’t know if he wants to assign different materials. The only thing what is clear is that he wants to use the same texture space on two different objects.

1 Like

So do I have to manually juxtapose the UVs?

It depends, Do you want to overlap the textures or make them fit well side by side?

I want to get rid of the seams between objects and achieve the same density of texels

If you select them both and enter edit mode, selecting all the faces, and then make a cube UV projection they should automatically be aligned in the UV space.

You just need then to take care of the faces you don’t want to follow that orientation but keep those together.

1 Like

as an option) Is it possible to automate this? Is there any addon?

I am sorry to say that I am the worse person to ask about addons in the entire world. Maybe @M-777 could help you with that.

1 Like

thanks for the answers, you helped me a lot)

1 Like

I am really glad to help.

You might find the Texel Density and UV-Packer add-ons helpful in making things easier for you.

1 Like

I’ve got one more question. This goes for UV Unwrap.
I unwrap a model with flat edges along the axes, but UV Unwrap makes rounds
the only way I can do it correctly is using Project from View


You can use the project from view too. Maybe you will need to alight the faces after. at some points.

Could you use the Follow Active Quads tool to reduce the whole island to a rectangular or square shape?

I made a test here and I could not reproduce the problem, maybe because my model is too regular. What is your blender version?

Unwrap here worked perfectly.

I use version 3.0