Selecting clear transform modifies actions

When I click Pose > Clear Transform in pose mode of an armature, it modifies the actions, even though I do not add keyframes. Specifically, it modifies “HandsTable5.2” in the attached blend file. It does this even if I select clear transform while another action is selected in the dope sheet. Why is Blender doing this? Is there a way to stop it from doing this?


add_action_test_20130913.blend (584 KB)

I believe… (all though I am not sure) what could be going on is that you dont’ have any key frames saved for your bones on frame 1… this is kind of standard practice… and that may be why the actions are not taking effect… (but I can’t say for sure… as I have never saved an action on an armature that did not have frame 1 frames saved on every bone… )

I tried changing the action “HandsTable5.2” to be keyed at frame 1 instead of frame 11 and the problem still happened. I think maybe I didn’t make the problem clear enough. The bone “HandIK.R” is keyed as an XYZ Euler with a value of (90,-5,-90), but when I do the following:

  1. Add a new action from the dope sheet
  2. Delete keyframes on the new action (but not the old action, “HandsTable5.2”)
  3. Select clear transform on location and rotation on the armture in pose mode
  4. Select “HandsTable5.2” in the dope sheet
    Then, the “HandIK.R” bone is has a value of (0,0,0). Something else strange about this is that “HandIK.L” is (90,5,90) like I want it to be.

I wrote a Python script to clear the transform and it seems to be working without modifying any actions. However, it would be nice if I could use the “clear transform” option from the pose menu.

import bpy

for b in bpy.context.selected_pose_bones:
    b.rotation_euler = [0,0,0]
    b.location = [0,0,0]

I took a look at this, and I’m not really sure what I am looking for. Maybe the file posted and the detailed description don’t match…

I downloaded the file from your first post, and as far as I can tell it’s working ok, but I didn’t look into it too much. I read thru your detailed post, looked to your file again, and I’m still lost. So I re-read this:

And I’m looking specifically at ‘HandIK.R’ and there is no keys for the rot of that bone:

There are keys set for the location, they are yellow in color in the transform panel. Rotations are set to quaternions, not eulers, and no keys are set for rot. I then cleared the pose for that bone thru the pose menu in the 3d view, and the bone’s location & rot change. I move thru the time line, and the bone returns to the keyed loc but not rot.

Just noticed, yes you do have keys set for euler rot, but your bone ‘HandIK.R’ is set to quaternions, try changing it back the eulers and see if it works correctly.

If that’s not the problem, please post an up to date file and description.


I just set the bone ‘HandIK.R’ to XYZ euler instead of quaternions, and that worked. I can’t set this thread as solved, however.

Try the ‘thread tools’ at the top of the first post…