Selecting Help, "Manual" & "Getting Start

If I select “Help” -> “Getting Started” in Blender 2.34, I get the “Python Script Error : Check Console” error. The console says:

File “<string>”, line 31, in ?
zipimport.ZipImportError: can’t decompress data; zlib not available

zlib.pyd is clearly in my Blender exe folder, so I’m not sure what’s up here.

Can anyone please help me out?


You need to be online. I just tested it and it works for me on Win XP and IE.


Eek, that’s no good. Can you give us some detailed system specs to help troubleshoot? i.e. Operating system, hardware, is Python installed, etc.


:o Python? Yes it’s installed and works, but I get no error message.

But these have nothing to do with python, no? They’re 2 HTML docs in the Blender folder. If offline I get the “No Connection” message, online it bypasses the docs and goes straight to the webpage when using the “Help” menu. I can however doubleclick the shortcuts (offline) and get to the docs.

Win XP, IE6
Blender is @ C:/Program Files/Blender
Help is @ C:/Program Files/Blender/Whatever
Getting Started is in the same folder (Blender)
(“Whatever” is the Windows Explorer name of the HTML docs but I can’t see exactly what they are while online cuz it’ll go to the webpage)

I can’t think of any other specs that would be useful.


He’s talking about the new Help menu, which uses Python scripts to launch a web browser.

I run broadband. I’m always online.

Anyway, I’m running Win2k SP4. Python is installed as well, so prehaps that has something to do with it.

Mozilla is my default browser. I tried making IE6 the default, but that didn’t help.