Selection issues

Hi I would like to know what im doing wrong. I am currently following CG cookies tutorial ( i ran into some trouble on the 3rd video. Hopefully some of you have done this tutorial.

When the artist deletes the first parts of the body, (the end caps) it doesn’t happen the same way for me and im getting only half or a quarter of a section deleted using “B” to select. It doesn’t start off doing this however. Somehow at random through the tutorial the B selection stops going through the entire side.

I have noted several things, such as blender doesn’t behave with axis locks unless im in a specific viewpoint like hitting numpad 1 or 3 in this case. I also needed to wrap my head around making sure im in edit mode or object mode, and i’ll follow up with saying i do make sure limit select is off, or in the selectoin the artist has it. other that i am new so not sure whats going on with the B select tool, i am in wire frame mode as well, or in solid mode when needed.

also i don’t think it’s related but when the Cylinder is first Rotated to point horizontal (video 2) his Axis manipulators are pointing different. The artist has the Z arrow pointing horizontally out of the object, whereas i still have mine pointing up. In my noobness i managed to at least figure out that if you change from Global to Local or vise versa i can manage to switch them, im not sure it matters but id like to follow the tut as best i can. Now i do think i need to know why my B selection isn’t working because that can be a functionality issue, because it’s like having mirror mode not mirroring what your trying to model, and that means it’s not working as designed. Sorry if that’s long winded, im trying to go through the manual and see if i create the problem the same way, and i hope it’s something minor. I DO indeed think enough to look at the verticies at the top right and make sure i have as many as the artist does when selected, i only had half of what the artist had when deleting the section for the cockpit. I figured this would be the best place to go, as i read up the manual i have no idea where it’s changing because when i start out i can B select the whole section front and back or Alt+RMB select to make sure i have a full selection.

I don’t think you’re going to get answers quickly, or at all, because you are reporting something that you assume others see (your screen and the tutorial) and can tell you the problem. I happen to have those videos, but I don’t want to play a detective so that I might be able to notice something and answer questions you didn’t ask. There are no questions in your post. I did a search for question mark since I only read half of it.

Instead it would be better to describe the issues a question at a time, show a full resolution image of the whole Blender interface to support you to ask the questions, show another of what you expected to happen instead if you can’t include them in the same shot. You can take screenshot in Blender by pressing ctrl+F3 (or window menu -> save screenshot). You might also notice that it takes much less writing when using visuals.

After you’ve written the questions, include your .blend file so that others can find out what causes the problems and show you (visually) what is wrong and/or what to do instead.

When you say the “B selection stops going through the entire side” is it like it’s selecting just the things closest to the camera? What is the state of the “Limit selection to visible” button, shown here?

hi this is what i get

Ok well, i went back through the manual, i also went back through the tut and found it was working. Not sure what i did.

I will show you here this is what i am supposed to get here:

And this was my results (before i was only getting half a circle deleted)

My result

So with that done I had a question about his selecting. I noticed at one part of the video he uses B select to UN-select a some verticies shown in the next two pictures

(if the formatting really comes out bad sorry i only have a few minutes of internet per day so here it is)

so my question is how is he able to UN-select with B? I actually like that method more than using B to add to the selections.

Also this is probably minor or might not affect anything, but my manipulators are rotated differently than his. I definitely went into Edit mode to make sure i rotated correctly at the beginning, im not sure why his Z (blue arrow) points up and mine doesn’t.

His manipulator:


To deselect with B-key:

Press B-key to activate box select
Use middle mouse button (MMB) to drag the selection box

Both of you have transform orientation set to local which means the manipulator widget orientates itself to the object. That in turn means your object is rotated but the rotation is unapplied. Unapplied rotation has an effect when you try to use a modifier that uses an axis, such as mirror modifier or shrinkwrap in project mode, and the axis doesn’t match what you see.

Object mode, properties panel (N) is where you see the object rotation. 0,0,0 means it’s aligned to global (world) axes. Ctrl+A -> rotation to apply it. Also if the scale isin’t 1,1,1, you should apply scale too.

Is there any way to use just B to unselect? Do you think he is using MMB to do that? Or is there a way to change that in user preferences? I haven’t seen it.

Thanks Ctrl+A worked.

To unselect using B key you have to hold the shift key down.

Ok well, now i have another problem. Not sure if i should start a new conversation.

In video #6 when using the array modifier to create the propellors I don’t have the “Empty” mesh. Is there something I’m supposed to download?

To add an Empty:
In Object Mode press Shift+A -> Empty

Box selection (B-key):
Left Mouse Button -> Add to selection
Middle Mouse Button -> Remove from selection
Shift+LMB -> Remove from selection

The only difference is which mouse button you press to draw the selection box.

Right what I’m saying is: i don’t have that selection option at all. I have “mesh, curve, surface, meatball, text” but I’m definitely not seeing “empty”. Im running Blender 2.7 …

Hmm. That is odd. Are you using the official 2.70, 2.70a or a nightly build from Build Bot? If you’re using 2.70 or 2.70a could you try a build bot version, please?

To help you continue with the tutorial though:
You can use any mesh for what Jonathan uses the Empty for. You could even add a cube, go into Edit Mode and delete all of the vertices if you really wanted.

Ah, I’m running 2.7a i believe that’s all i could find off the main website. I’ve heard of builds…they are like additions from other supporters right? Ok i’ll just delete vertices and let the center object dot hang in there, i’ll try both since i like the other features I’m seeing.

Builds can be official or unofficial. I believe the build bot ones are official nightly builds. Nightly builds will have the newest features, but will also have the newest bugs. They’re intended for testing and bug finding, but they also contain many bug fixes; which is why I recommend trying one if you’re experiencing a potential bug.

I’ve just checked 2.70a and the Empty option is still there in the menu.
It’s located under Armature and Lattice, not with Mesh, Curve, Surface, Metaball and Text.

It’s funny. I found where empty was (yes under armature) but now that i have used it once. Blender went and put it in my mesh menu now…blender is weird.

Good news is i finished the tutorial, or mostly. I ran into some Array modifier problems

And on this i tried scaling down the rivets but it didn’t work, somehow they are offset and are floating just above the nose cone

and here

Also on the nose cone i have some creasing either from the shrink-wrap mod or the mirror mod. I had this all over my plane but managed to fix it all.