Selective Lighting with overlapping objects - Cycles

I would like one light (selected orange) to effect only one of the objects (in Green)

I have followed what was suggested here: Stop light hitting a specific object?

I placed the Grill and the light on separate layers and did the whole exclusion process.

But this did not work due to the grills being behind the face of the object, this object has other stuff within in so I can’t simply place the grill layer behind the other.

ALSO, It would be extremely helpful if in the Viewport that the light from layer 2 did not effect what was in layer 1. Is there some way to enable this in Cycles?

I’m new to blender so apologies if this is a noob mistake, I’ve done a lot of research on the topics but haven’t made any progress

The idea here is to create a light reflection on the grill, but have that one reflective based light only effect the grill

THANK YOU! :slight_smile:

I cant upload this specific blend file because its close to a gig.

Hi, you can get the effect you want by rendering object masks in another render layer and using those to composite the image:

You can assign an object id for use in the compositor here:

Put each object and lamp on its on layer, and make a render layer for each set of objects and lights. The objects all have to be in the same render layer in order for the masks from them to influence each other, so you’ll need to render an extra render layer just for getting the object ID pass (remember to enable the object id pass in this extra render layer). I also excluded all the lamps and turned off the environment light on this layer in order to speed up the render.

Here is the node setup:

and here is the blend file:object masks.blend (2.1 MB)

1 Like

Thank you very much Zanzio, by the looks of your images that is in fact the look that I was going for.
I’ve been out of office but I’ll get back to you on the results asap

I’m extremely grateful for the quick and thorough explanation, it’ll really help me.