Selective Lighting with Volume Scatter

I have an interesting spherical object. I have a light source within it so that with volume scatter I have god rays coming out of the cracks. Unfortunately, with only the light source from within you can’t see the object’s surface nearly well enough and any light I try to shine on the object gets caught up in the volume scatter which ruins the image.

Is there any way to make one light source be unaffected by the volume scatter?

I am using cycles render.

Object properties > Ray visibility, uncheck “volume scatter”

I’ve tried this but for some reason I can then no longer see the volume scatter from the light emitting object within the sphere. No matter how little light from outside the sphere is added.