Serious Bug on Texturing

Hello Blender friends :),
It’s not often that I ask a question on the web, but here I’m really stumped. :frowning:

I think I noticed a serious bug in blender’s texturing.

After several experiments under multiple versions of blender, several OS (windows/linux), GPUs (Radeon/Nvidia) and PCs, the painting generates artifacts.
It generates dots (pixels) on the drawn areas.

The more you increase the resolution (4K,8K,16K), the more visible and very disturbing it is.
I really think I have tried everything to fix this problem without success. :frowning:

To try, start by subdividing a cube with 3 or 4 iterations and create a 16K texture.
Start painting on it… You will see dots and lines.

… Any idea ? :slight_smile:

Thanks for reading. :slight_smile:



Can’t offer anything useful, but I too have encountered similar behavior. Usually just a few pixels (on 2k textures). After changing zoom and/or view angle I could paint over it.

What I haven’t noticed before is that it seems to occur only on diagonal “edges” inside quads :thinking:
edit. huh, wrong observation: it occurs at edges that have 45 degree angle in UV map…

Exactly :face_with_monocle:
At the moment I am stuck, I hope someone will find the solution.

Thanks for your comment. :slight_smile:

I’ve noticed that this bug affects all resolutions actually.

You can try on a 1K Texture the fill option.
You’ll notice lines and dots around the mesh.

Still no ideas? ^^’

Even the “Quick Edit” (Edit a snapshot of the 3D Viewport in an external image editor.) doesn’t fix this problem. :confused:

If any of you know a Developer, please pass the info on :wink: :slight_smile:
Thanks for reading. :slight_smile:



A solution I have for the lines showing up is to scale down the UVMapping so there is blank boarder around the UVMap Islands. Then paint the model using a bleed of at least 8px.

That’s just the thing, bleed doesn’t affect this issue at all. Also it happens “inside” the island

StrayBillie answered for me. :slight_smile:
Thanks for your comments friends.

Hmmm…that is strange as I have never seen this on any version…and I have an older AMD processor 6-core with Nvidia 2070 RTX…and using a 32" HDMI TV to view., (I’m old)

:thinking: okay, really interesting…

Are you sure ? :sweat: :slight_smile: no dots ?
My CPU is a Ryzen 3900x :slight_smile:
What is your CPU please ?
at intel have the same problem ? :face_with_monocle:

I specify, it’s the polypainting that is buggy, not the texture editor.

I hope I won’t have to change my PC… :sweat_smile:

Thanks for your help. :wink:

it is over 6 years old…started out as
Cybertron PC Hellion (Blue) TGM1213J Gaming PC (3.5 GHz AMD FX-6300 6-Core, 2GB GeForce GT740, 16GB DDR3 1600MHz, 1TB HDD, WiFi, Windows 10 Home 64-Bit
Updated Ram and GPU

It may be a bug related to Ryzen Cpus… :thinking:
It doesn’t help me much but I am reassured to see that this problem is not common to all.

Thanks for the info friend. :slight_smile:

1 Like

If you think it’s a bug, please report it.
The devs normally don’t hang out here, and if you make a proper report of it with all steps involved you will get more traction.
Also, be sure you can reproduce it every time. :wink:

1 Like

Indeed, this is exactly what I was thinking of doing tomorrow on the Blender github. :slight_smile:
Did you also have another link to propose ?

I just experimented the bug on a friend’s laptop.
Old intel CPU and same bug.
I don’t think the CPU is the cause.
I think this bug concerns everyone. Really :confused:

Hopefully the devs will fix this bug…

Thanks for your comments friends :slight_smile:

Just use the bug report option in Blender, or -if you have a account there- post it on the blender devtalk forum.


1 Like

I followed your advice. :slight_smile:

In the meantime, I’m stuck.
If any of you have the same problem please follow rob’s advice as well as posting it here.

Thank you all. :slight_smile: