Set a shortcut to switch on and off emulate 3 button mouse?

Hello Folks,
Is it possible to set a shortcut to switch on and off emulate 3 button mouse?
I’m a mac user working with a wacom - my everyday go to app is ZBrush.
For the most part I’m very happy to set left click as default with emulate 3 button mouse switched on also.

I discovered today that the selection shortcuts for edges and faces etc are not available in this mode. I’ve been using cntrl+e and selecting the edgeloops options from that menu which is far slower. Temporarily switching off the 3 button mouse emulation would let me access these shortcuts quickly.

I can’t see a way to set a shortcut for this in the user preferences input section and am emotionally prepared to hear that it is not possible.

Is it?

Input -> 3D View -> 3D View (Global)

Or, you can edit your keymap to actually handle mouse presses as presses and mouse clicks as clicks (Alt+Select is set up as Press, not Click by default, which is why Alt+LMB does not work for loop selection). This, however, is a somewhat tedious task.

1 Like

Thank you so much Stan,
as a newbie I shall now have to find a video or web page to understand the process of how to actually create the input for the advice you have given me.

From a search I can see various inputs for Context Toggle in such sections as Weight Paint etc but as yet I do not know how to set up what you suggest and where I should set it.

I’m a little scared of screwing anything up - although I joined the forum in 2008 it’s taken me 7 years to finally sit down and decide to work with Blender :-). The first time I tried I ran away scared.

Many thanks

Thank you so much!!
Press q to use selection shortcuts, press q to navigate around the form, press q again to use selection shortcuts,press again q to navigate etc etc….


Hey! Thank you for this solution, however, I tried this in 2.8 and it didn’t work. Do you guys have another solution for 2.8?

In 2.7x it was:


In 2.8 it is:


1 Like

William, thank you so much! It worked like a charm!

1 Like

People, just use shift + middle mouse, I’ve been struggling with this problem ever since I switched to a new PC laptop after owning a MacBook Pro.

for non geek folks:

  • go to preferences > keymap
  • under the ‘Window’ dropdown scroll down and click ‘Add new’
  • a new entry named ‘none’ will be added, open it
  • In ‘Identifier’ where you see ‘none’ type instead: wm.context_toggle and hit Enter
  • in ‘Context attributes’ type: preferences.inputs.use_mouse_emulate_3_button and hit Enter
  • choose your shortcut.