Set OBJ import/export defaults?

Something that’s EXTREMELY annoying (my user name was gonna be BlenderAnnoysMe) is that the import default for .obj files in Blender is Y up and -Z forward. Z should ALWAYS be the up and down axis and Y+ should ALWAYS be forward.

I don’t know who made the .obj import/export plugin - but they need to go back to Blender Plugin Maker School.

This is terrible for a number of reasons:

  1. Imported meshes are rotated sideways

  2. Exported meshes are exported sideways

  3. It’s annoying to have to fix it if I forget to change it during import/export

  4. Who did this? They need to not be doing this.

  5. Nobody ever exports from Maya/3DS Max/anywhere else with y+ up.

I don’t know who else uses Y+ as their vertical axis, but if you do this you are one strange person.

So my question is, is there a way to change the default import axis, or am I destined to be annoyed by this for all eternity? I’m gonna be turning over in my grave knowing this annoying problem was never fixed.

Moved from “General Forums > Blender and CG Discussions” to “Support > Technical Support”

You can read the text of the add-on (as well as the information for it in the Add-on section of User Preferences) to see who wrote the add-on. You can also file a bug report to suggest your change to it (preferably with a patch). Though if you were to do that, I would recommend using more courteous language.

if I had to guess you would edit line 57 in the init.py file for addon https://developer.blender.org/diffusion/BA/browse/master/io_scene_obj/init.py;c88411ff7776a2db5d6ef6117a1b2faa42a95611$57 I haven’t tried so not 100%. I don’t remember my obj being sideways ,but I’ve been exporting as fbx lately.

I’ll give that a shot. Should I use a hex editor or is Notepad++ enough?

Holy moley, thanks, that worked. This was really starting to annoy me.

Sorry to dredge up a zombie post, but I came here looking for the place to try to fix something: the fact that the OBJ exporter has “write out MTL file” and “use materials in obj file” as the same setting so you literally CANNOT export an OBJ using this as-is with usemtl lines in it, without having the stupid .mtl file that nobody cares about tag along and waste space.

So I sympathise with DeathclawButt’s frustration in the annoyance here. At least their setting was one that could be written over in the init. Mine will require actually rewriting a few bits of the exporter. But at least I know where the stuff is buried now. But it’s really annoying that we can’t just save exports defaults as-is without having to select. Seriously, my export preset until I figured out where to change things was titled “Frakking use this, Jesus FC”. That’s how irritating this is.

Only one leeeetle bitty thing, DeathclawButt: Y-up IS actually the OBJ file format standard. Source: I’m the guy who wrote the Perl OBJ module (Model3D::WavefrontObject) and I have even written OBJ files in vim by hand.

So I do sincerely sympathise with your frustration. But you’re wrong.