Shading?/Culling? Artifacts in 2.66

The following render shows the artifact my render produces. I want to get rid of this (the darky areas in the skirt):

The following render shows the result I expect, I had to delete skirt inner faces to get this one:

Maybe my method to achieve two sided faces is wrong. I simply realized how it can be done, no tutorial. But I remember to have used it in the past with success in 2.49.

The model is for real time rendering, very low poly. For the skirt inner faces I duplicated the outer faces, then flip normals, then assign new UVs. I didn’t scale the inner faces, should not be necessary if I understand correctly what the renderer will do considering normals direction.

Ignore artifacts in upper body. Those faces need to exists but a version of the model without all the body faces occluded by cloth will be used most of the time. But I need the skirt inner faces always present.

Blender Internal
Environment Lightning 0.5
1 light source, lamp, in front of character

Any tip appreciated.

it’s kind of hard to see, but it looks like you have doubles. whenever you have two polygons sharing the exact same space you get ‘z-fighting’ which is what you have there. try using the solidify modifier, or google for blender two sided shading nodes to get two sided faces ( with two materials ) without thickness.

After googling and googling I came to the conclusion that Blender, now, cannot produce renders with back face culling. So if I want to “fake” two sided polygons with different materials in each side It will result in “z-fighting”. The solidify modifier is similar to manually duplicate the outer faces, then scale a bit inwards, then flip normals and then connect to all vertices in the border. It may work to produce some renders of the character when needed.

Could not find any node configuration. I only looked in the first result page, I will try harder later.

As the principal use of the character is to be used in a game engine, I have a feeling that the engine will cull the back of the faces and then I will get what I expect. So I should be able to continue the modelling with this assumption. Cannot export the model right now only to test this but It will probably work. It may even work in the Blender internal Game engine.

I have the dates of the release notes / features recorded, I’ll see if I can find some documentation for you…brb…

here are the release notes…

Thank you.

Yes, customize the material nodes, looks like the way to achieve what I want, remove the back faces from the render from certain materials, so I don’t have to solidify.

What I did was this. Make both, skirt outer and inner materials to use shader nodes. Add a material node, set the material to the corresponding one (outer for outer nodes, inner for inner nodes). Connect color to Output color. Then add Input->Geometry node. Connect Front/Back to Output alpha.

In both materials enable transparency, Z-Transparency to be specific. Set Alpha to 0.0 (by default it is 1.0).

Inner material should have “Traceable” disabled. Outer material can have “Traceable” enabled.

The part of having to disable Traceable in inner material does not convince me. Any comments about this subject appreciated.

I won’t post a render from an obscene angle, but now it renders as I want.