shift ctrl left-click in node editor doesn't work

Hello. Thank you for watching.

Sometimes, shift ctrl left-click (a hot key that directly connects a node into the material surface) doesn’t work. Do you have any idea to fix this?

1 Like

You will need the enable the NodeWrangler addon for this function http://wiki.blender.org/index.php/Extensions:2.6/Py/Scripts/Nodes/Node_Wrangler

Just like in the compositor, you can now Ctrl+Shift+Click a node to view it! A temporary emission shader is created so that there’s no shading on the object – the clicked node is connected to this shader and then to the output. If a shader is clicked, this emission node is skipped and the clicked node is connected straight to the output.

6 Likes

Oh, that was it! Thank you very much!

i Turned On But I Was Creating A Forest And ctrl++shift left clicking on ColorMap doesnt Work If Someone Have And Idea Please Tell Me.

im unable to download with this link is there any other way

The Node Wrangler add-on is bundled with Blender nowadays, all you need do is enable it.

how do i enable it

Go to Edit > Preferences > Add-ons and search “Node Wrangler”, and check the box left to it. You are good to go with the shortcut now!

I was having a tough time solving this. Even after enabling the Node Wrangler, ctrl+shift+leftClick, that didn’t work for me. Then that’s how I got it right >> I just opened the Blender with “Run as Administrator”. Then I opened my project file form there. ctrl+shift+LMB works again with notes.

1 Like

yup now it’s working ty.