Shift + D does not work in object mode

Hi I have an issue.

When I press shift+D in objectmode, the mesh I am selecting does not duplicates.

I asked on discord communities about this problem, one guy told me he had a similar situation and fixed itself for some reason.

Here is what I tried:

  • uninstalling blender, installing it again.
  • disabling some addons here and there to check if one of them was causing some trouble.
  • changing keyboard assignment and trying different key combos for the shift+D action
  • changing keyboard layout
  • using another keyboard
  • restarting my pc

Here I show an image where the shift+D duplicate mesh is evidently enabled. I already checked that.

What is the problem? Do you have same issue? Only 1 person told me he had a similar issue, but on stack exchange I see no answers to this problem. Am I the only one that cannot duplicate objects in blender?

I use windows 11, and I run blender 3.4.1, latest version downloaded today.

If you can tell me how to fix this problem you really help me alot because I use shift D on a regular.

Immagine 2023-01-08 012430

Welcome to BA :slight_smile:
What kind of object are you trying to duplicate? Does this work, for instance, on the default cube in a new file?

Hi. Thanks for answering and sorry if I haven’t made a presentation.

I’m a guy who learned some blender while following YouTube tutorials.

Well, my issue exists in object mode. Every object I select and try to duplicate with shift+d instead stays still and does not duplicates.

Before it was working, at some point blender stoped duplicating objects.

In edit mode shift+d still does the job.

Alt+D is also disabled for some reason.

Obviously I tried to open another new file, and did all the steps I listed on my message. Nothing works. Is it a bug? I will try to download blender 3.5 alpha to see if this stuff is fixed or not

This is very odd, I’ve used 3.4.1 myself a few times and never experienced this issue, and your keymap is correct. Are you on PC or Mac?

Yepp very odd… 3.4.1 linux debian here… no problem…

+1 for trying to disable some addons and even using different keymap layouts and also telling us…

I’m not familiar with Windows11… (sadly or luckily… :stuck_out_tongue_winking_eye: )

Please answer this question!

It is likely that you are trying to duplicate a linked element, but you need to answer joseph’s question please or we’ll have no idea.

Good luck.

1 Like

You wouldn’t believe how many (new and not so new) users ask the weirdest questions here and give less or almost no information about what their real problem is or whatever they did try already (i tried everthing…) or what magic they expect from blender using megabytes overs megabytes on data (geometry an d textures) while their hardware and skill is on the lower part of spectrum of possibilities :stuck_out_tongue_winking_eye:

Yes I tried to duplicate the cube and I cannot.

In edit mode, I can duplicate everything I select. Only in object mode it does not work

Go to scripting workspace and test it there. Is there an operator added to the list in the lower left info panel if you try ? It should be starting with bpy.ops.object.duplicate_move(…)

I tell you what I did.

I downloaded 3.5 alpha to see if anything changed. I loaded the settings of 3.4.1. The problem persists.

I decided to load the factory settings on the 3.5, did another experiment. This time it worked, shift+D works.

So I think there is something that I changed for error. Maybe I disabled this function somewhere, because if I load the factory settings, everything works as intended. What could I have changed?

I can only describe the situation. I was using blender normally, and I was watching a tutorial, after some minutes I go back to blender, press shift+D and this time the keyboard combo does not work. Maybe I pushed a button, what could I have pushed? In the option panel I have changed nothing. I will try to compare my 3.5 factory settings to the 3.4 to see if there are visible changes in the interface.

My current assumption is that there has to be conflict with an addon, because I dont see relevant changes between the factory reset version and the 3.4 I was using, since I changed almost nothing. But why shift+D stopped working suddenly? I did install 2 addons I will try to remove both

Spotted the problem. It is an addon that is causing this. I will contact the developer to tell him about this issue, he already answered me so probably its not going to be an issue.

Since this was a long story… and some preople got involved… could you share the name of it?

1 Like

not yet. I contacted developer. I want to figure out if it was an user error that I did or an unintended bug from the addon. since the developer is answering questions I think its not going to be an issue.

Well it may be that you deleted the original shortcut or accidently set another one or an addon has set the same one. If an addon sets a shortcut it has a higher priority than shortcuts than come shipped with blender. But then another operator would react when you press the shortcut. Thats why I asked you to check the info panel.

So once again, check if the info panel lists a message of another operator if you try the shortcut in 3.4 and if theres another one than I listed, tell us which one.

Beside that you can search for the keyboard shortcut in the keymap preferences to see if you simply accidently assigned one.

Edit : Somehow missed some of your answers. :face_with_thermometer: Great if you found the problems origin.

It is automatically disabled. But I contacted the developer of the addon and he told me that this is a bug and I reported it. I suppose he will take a look at it. So I think this issue is solved. I can just disable and enable the addon when I need it.