Shortcuts Issue with Linux Mint 19

In Windows I normally hold Alt and drag to Orbit around an object or the scene. But Linux Mint seems to use the same combination to move windows.
How are you Linux users dealing with this?
I went to the Shortcuts in the Keyboard panel but I can’t locate the one using Alt + RMB dragging


I suppose you mean behavior with “Emulate 3 Button Mouse” option enabled. Shortcuts behavior is not the same in all Linux desktops/window manager. I’m not sure which of them you are using. You see if this is helpful:

1 Like

I think this is just what I need!
Thank you YAFU :slight_smile:


I guess I spoke too soon :frowning:
I tried the command line suggested, and I also logged off just in case. But I am holding the Super key (Windows key) and left-clicking but it doesn’t work.

I am a KDE user. I think what that command does is change behavior of Alt key to Super key for GNOME. So, after doing this, you should be able to use Alt key inside Blender.
In Blender for Linux, do you have “Emulate 3 Button Mouse” option enabled from Blender settings, right?

1 Like

Yeah, I use Linux Mint as well. As YAFU says, just change the shortcut to Super and it will work as you expect. :slight_smile:

Just be aware that if your keyboard doesn’t have a Super key (usually the key with the Windows symbol) that you will not be able to move windows with it (or just choose another key).

Yes, I do have the “Emulate 3 Button Mouse” option enabled.
Still no go.

But shouldn’t I make it available by releasing it from the Linux Mint’s Keyboard panel first?
If so, which binding is that?

Yes, open the system settings tool and go to “Windows” and the “Behavior” tab, this is the setting to change:

1 Like

That which is explained there in Blender manual does not require any other change in configuration of Blender shortcuts. You just have to apply the command and logout/login or restart the PC. Then opening Blender, Alt key should work as it works for you in Windows (as long as you have “Emulate 3 Button Mouse” enabled if you want that orbit behavior)
But I’m not sure if the desktop you’re using in Mint is GNOME. If this is other desktop or one derivative of GNOME, then it would be necessary to see if what is explained in Blender manual is still compatible.
Do you know exactly which version of Mint you are using and what is the Linux Desktop that it uses?

Oh, @Grimm shows that Mint has a GUI to configure shortcuts. I think the steps to do it from that GUI in Mint should be mentioned in that Blender manual link I shared above.

Mint defaults to the Cinnamon desktop, or you can install it with the Mate desktop. I’m showing the Cinnamon interface. :slight_smile:

Well, the one thing I have not done is to restart. So I’ll do that now just in case.

Thanks Grimm, I’ll look into that as soon as I return, from a restart (if I still need it).

If you logged out and logged in session, I think that is enough. You try to modify shorcuts from interface that Grimm showed you.

I had done that before, without success. So that’s why I figured I would restart this time.

But, I did what Grimm suggested and now it’s working!!! Finally!

Thank you guys for being so helpful and patient! :slight_smile:


You should mark as the Solution the Grimm post where he shows the Mint interface.