SimbiontBlender 0.5.0: updated for Blender 2.4

For those not already familiar with SimbiontBlender, it is a combination texture plugin and python script which allow you to use DarkTree procedural textures within Blender. The DarkTree script editor is commercial software, but there is a rather extensive library of freely available pre-made scripts.
Available here: (I’m not affiliated with these guys, though I think the software is very cool).

Anway, I’ve updated SimbiontBlender to work with the latest Blender version. Actually this version is a major rewrite that fixes all known bugs and makes the user interface quite a bit better. Also, full script tweak and channel mapping state persists between sessions.

This release requires that you have a full, working python2.4 install and have your pythonpath set correctly.

The new release is here:

The tutorial is here (this is now somewhat out of date, though the concepts still apply):


Paul Bridger

Thanks Paul!


Cool, been waiting for this one. I’ll give it a once over and post any bugs as soon as I can.

Just downloaded this, going to give it a spin tonight.

Two words: “YOU ROCK!” :smiley:

I was going to try to hack the old version to work, but you beat me to it! Thanks for making this, I love my Darktrees!

Ok as soon as I try to load a darktree I get this error:

Traceback &lt;most recent call last&gt;:
   File "&lt;string&gt;", line 219, in drawInterface
   File "&lt;string&gt;", line 197, in drawSetup
   File "&lt;string&gt;", line 281, in onResult
   File "&lt;string&gt;", line 969, in __onBrowseSucceeded
   File "&lt;string&gt;", line 123, in saveConfig
IOError: [Errno 2] No such file or directory: 'c:\\Program Files\\Blender Foundation\\.blender\\scripts\\SimbiontBlender\\default.cfg'

Now I’m guessing that this is because I moved the script out of the sub-directory, which isn’t good as last time I checked there is a bug or whatever you want to call it in blender that prevents the script menus from updating correctly if there are other sub-directories in the scripts folder.

I’ve had to deal with this before and just thought I’d mention it.

Also in the installer it adds the folder blender twice such as:

"C:\Program Files\Blender Foundation\Blender\Blender"

PS: Once I hacked the path string in the script it loads them, now to have some fun.

Well I reinstalled under the default paths just to be sure any bugs weren’t of my own making.

Seems when I delete a darktree from the list and then add a new one the count (ID) isn’t reset until I reload the script.

Also would it be possible for it to load the darktree and settings even if the script hasn’t been loaded? I’d hate to have to keep every darktree I ever used in the script’s list so I don’t mess up other saved blends.

I’ll get onto fixing this bug in a couple of days - right now I am very busy.

Thanks very much for the bug report.

Great plugin! Nice to see there are some darktrees for download as well…

Fun stuff. :slight_smile:

Thanks btw for this plugin. You’re the man.

Oh wow, your the Axiomatic guy from the OGRE forums huh? I thought the demo was pretty fun.

(sorry to threadjack, I just noticed the ten-ninjas website)

Yep, that’s me. :slight_smile:

I bet you can guess how I generated the skyboxes for the game…

no linux… :frowning:

You have to take that up with Darkling Simulations, you’d need to recompile the DLLs I guess.

So I finally got around to using this.

In your tutorial you say there are two parts, the script and the plug-in… and it only took me about 10 mintues to figure it out, but for those who have never used a plug-in:

under texture button, texture tab, texture type, choose plug-in.

another panel will coem up, and ask you to choose the plugin. It should be in a folder called plugins/SimbiontBlender in the same directory as your blender.exe, the file you need to choose is SimbiontBlenderDll.dll.

Viola… enjoy!

This is great pbridger, having lots of fun exploring it ATM, but it seems I can only add one material per object using simbiont blender… is this true?

EDIT: It’s not entirely true, allthoguh everything seems a little wonky… like a refresh texture and materials button somewhere is needed… :S

@NeOmega: Thx for the tip.

But I still can’t get it to work. :frowning:

Anybody got any clue what’s going wrong? I guess it’s the first box in the python window, but I can’t figure out which value to fill in. Or did I do something else wrong?

python window:

texture window:

resulting render:

I am trying to use the technohull texture. It looks really great, except that it has colored blocks, and you can chage their hue, but not their sturation, so I looked through the .dsts file in notebook, and they appear to be hand editable, but I can’t find where the saturation could be turned down, (so all the panels are gray)…

…any hints?

EDIT: Damn I’m smart… :stuck_out_tongue:

changed two values in Control 4 : Randomizer Color
DarkData: 6, -2, 200
Trans_0 : -2.18557e-008, 1, 0, 0
Trans_1 : -1, -8.74228e-008, 0, 0
Trans_2 : 0, 0, 2, 0
Input_Seed : 2
Hue_Minimum : 0.04
Hue_Maximum : 0.095
Saturation_Minimum : 0
Saturation_Maximum : 0 I changed these two to zero, and it worked! I then added just a smidgen of saturation, for a little variety
Value_Minimum : 0.57
Value_Maximum : 0.65

EDIT II: Does this have an 11 darktree limit?

I have the same problem as mrCarnivore… :frowning:

@mrCarnivore, Temaruk, and anybody else with the same problem -

try loading a different DarkTree and get the material editor to re-render the preview - bingo. Then you can reload the original one and it should work fine.

Worked for me, anyway.

It seems in Blender, I can only choose ID 0 - 10, which limits it to 11 darktrees.

Is there any way to get more, maybe through editing the script?

Hi Simbiont is not working with latest version of blender. Is it possible to get an update whe n you have time? I am having python script error. (no module named simbiontblenderdll