Simple flag in EEVEE gives weird artifacts

Hi Guys,

Like the title says: Simple flag in EEVEE gives weird artifacts.

Here’s the video: vlag.mp4

Selfcollision is on, stating this, because others had the same problems and selfcollision was turned off.

In cycles eveything looks great. But in EEVEE my flag has holes and jagged edges.
Tried with and without subsurf modifier. Also tried the solidify modifier. Tried the modifiers before and after the cloth sim.

What am I missing? For these kind of simple things EEVEE quality is more than enough and takes only 1% of the time it would take cycles.

Have you tried increasing the quality steps overall and in self collision?

Jup, started on the default 5, moved up to 12. No difference.

Cycles is good with all settings, 5, 8 12, doesn’t matter.

It the mesh all quads and the normals right? I would rather simulate the flag as a plane and put on a solidify modifier.


I just use import images as planes. Subdivide, make some pins, add a wind force field and then do the cloth simulation.

Can you test it without the solidify? Maybe it has to be applied for the self collision to be effected. When its not it i will try it in a test scene so see the problem. Now i am just guessing

EDIT: Have you looked up a tutorial about it?

I don’t use the solidify.

And yes, I learned this trick from a tutorial. But that was when eevee didn’t exist :smiley:

Change the blend type of the material to opaque that should solve it… Was a tough one but its caused by the automatic material from import images as planes. The rest is playing with the margin of self collision

Thanks! Haven’t tried the blend type thing. Cycles is running now, so will have to wait until tomorrow.
Glad my question was a tough one though :wink:

Wow, that was the solution. Would have never thought of that. Thank you sooooo much!

1 Like