Simple problem: No audio

Hi, I just did my first animation with audio, but there seems to be something I am missing. Whether I do a direct-to-file animation or use the video sequencer, no audio goes into the video file. I tried both Quicktime and AVI Raw, same result. It plays the audio fine when I press Alt+A in the camera view in Blender, but when everything is rendered out, no luck, no audio.

What am I missing here?

Cognis are you using the Ffmpeg format? And did you press the ‘multiplex audio’ button in the audio tab section?

If yes to all the above, could be that you got the wrong video codec to the wrong output format. From memory I think mpeg1 works with everything, mpeg4 is pretty good too.

Oh dear… this is embarassing, but I have absolutely no idea what you are talking about. I simply opened Blender, open the video sequencer window, put in a video strip with no audio, and put in an audio strip, then chose “Do Sequence” and clicked Animate.

I am 100% noob when it comes to Blender and Audio. I use the windows version, if that has anything to say. Other than that, I am lost and think I need a hug :frowning:

I found something rather troubling in the Blender: Noob to Pro guide:

Once you’re reasonably happy, it’s time to combine the audio and video and watch the result. Since Blender can’t do muxing (combined audio/video) you’ll need to composite it with the editing software of your choice (OSX users can use recent versions of iMovie, virtualDub is often recommended for Windows users and Avidemux2 is often recommended for Linux users.).

Is that true? Does Blender not have the ability to render sound into a standard video file??

Attached is what I mean. In F10 you simply change the default jpg format and replace it with the FFMpeg format (second from the bottom in that little menu pop up box). Then go to the audio tab and press ‘multiplex’ button.

Cognis, who ever wrote that must of been using windows, because the Linux Blender version has had FFMpeg included for a while now. And who knows, MAYBE the new 2.43 has FFMpeg for windows as well. But I can’t be sure because I don’t use Bill Gates’ crappy operating system. :slight_smile:


sigh I need to stop putting off that Windows to Linux shift… Nope, no FFMpeg in the Windows version.

Cognis, sorry to hear that buddy, never fear, you windows users have always got Virtual dub.

Or get the latest copy of Linux from your news agent for just a few bob. There’s Suse, Mepis etc. There’s so many to pick from.

Seems Ubuntu is popular amongst Blenderheads… Are there any particular differences in performance (of Blender) depending on version?

For linux, I now use the ‘cutting edge’ Sabayon. …and my render times are the same as I had with Ubuntu.
Most linux distros like Ubuntu, sabayon, Mepis ect… have an installer that makes it very easy to dual-boot ( at least with XP, Vista is tricky, and tries to wipe out linux).
Dual booting is a nice way to change to linux gradualy.
Heres the wierd thing; I just mixed a video for youtube. Blenders’ seq editor woudn’t interlace the audio in windows, and I can’t hear the audio while editing in linux.
So I ended up editing it together in Blender/windows, and interlacing it in Blender/Linux.

Ric: This was an old thread; FFMPEG is now in the Blender Windows version. Blender’s VSE should mix in audio - I do it all the time. I usually use the MP3 audio codec with the XVID video codec.

Heh. True. And I had been looking for interlace in the avi codec controls Doh!
I still can’t get sound with 2.45 in linux but I’m trying things. Sometimes it make a difference what order I compile the pieces in.