simple question: how make cube with sphere in it show semi-transparent in Game Engine


(olderLearner) #1

2.49b: in GE, with a sphere inside the cube, how can I make the cube show semi-transparent so sphere can be seen?


(HG1) #2

In the material buttons (F5) enable ZTransp and decrease the A value (Alpha).


(olderLearner) #3

hmm, that’s what I had tried, but it didn’t/doesn’t work, what on earth am I doing wrong or NOT doing??

Here it is: http://www.mediafire.com/download.php?eoiy2ui657p5f4f


(Monster) #4

Fading and Transparency for all Shading modes. It contains semi-transparency for all material modes.


(HG1) #5

Semi material transparency only working in GLSL and multitexture material mode in Textured mode.

Attachments

cubeTransparent.blend (60.6 KB)


(olderLearner) #6

sorry, I’m not sure I understand; the cube/sphere was just an example, what I really have is some downloaded objects (human skull and brain), which are apparently in Textured mode, as far as I can tell, so my question is really how can I make the skull semi-transparent, when it and brain structures are apparently in Textured mode?

Here’s a demo blend of the skull & two brain parts:


(Richard Marklew) #7

Change to GLSL mode (from the Game menu if I recall) and you’ll see transparency in the 3d viewport while in textured mode.
This is supposing you have a graphics card that supports GLSL


(HG1) #8

Your file was in soldi mode not switched to textured mode.


Material transparency works in GLSL and Multitexture mode.

Multitexture:

  1. Switch to texture mode.
  2. Multitexture you need to unwrap the skull (Tab-key = edit mode, select all faces, U-key unwrap).
  3. After that open the Editing button (F9) --> Tacture Face --> enable Alpha.
  4. Then press the copy button. Tab-key to leave the edit mode.
  5. Change to the material buttons (F5) enable ZTransp and decrease the A value (Alpha).

GLSL:

  1. Switch to texture mode.
  2. You need to setup the light(s) (type or strenght) if you see a black material.
  3. Change to the material buttons (F5) enable ZTransp and decrease the A value (Alpha).

I changed your File:


(olderLearner) #9

Thank you HG1, that works (I didn’t understand your earlier reference to Textured Mode, but including a pic of the Draw Type menu helped a lot, thanks for including that!)

And thanks Richard, too; I’d tried switching to GLSL previously, and got either black or white cutouts, so gave up on it, not knowing that I apparently needed Texture mode to utilize transparency.

Am I right in thinking that the Textured Mode relates to both the 3D view and the view in the GE, and NOT to individual objects?

I ask because the look of the brain structures is somewhat different in Textured Mode + GLSL, and Solid Mode + Multitexture Materials, looking somewhat better in Solid Mode + Multitexture, so I thought to apply Textured mode to skull and Solid mode to brain structures, but found that that didn’t work at all, so apparently Texture/Solid modes apply to the view of everything at the same time, can’t apply one mode to some objects, and the other mode to other objects.

I’ll try doing it in multitexture and see if I like that better, thanks again to you both for your help, I’ll be needing a lot more as I continue!


(olderLearner) #10

step 4, “press the copy button”: which copy button, there’s 5! I pressed the one in the middle one on the bottom, copy tex, I think; result: transparency in GE works, but in 3D view, I get a white silhouette instead of a regular view of the model.

edit: looks like I can switch back & forth between Texture and Solid mode: Texture to get transparent skull in GE, Solid to see what’s there in 3D view.

But I’m still not sure which COPY button was correct to push.


(HG1) #11

Am I right in thinking that the Textured Mode relates to both the 3D view and the view in the GE, and NOT to individual objects?

Yes. It is a global viev setting.

so I thought to apply Textured mode to skull and Solid mode to brain structures

That did not work.

To get a similar look for the brain parts in GLSL as in Solid Mode + Multitexture set in Material --> Shaders the specularity to 0.000.

transparency in GE works, but in 3D view, I get a white silhouette instead of a regular view of the model.

Yes that is so. You can’t cahnge that. Material transparency in the Viewport works only in GLSl + Texture and Multitexture + Solid Mode. Only when you add a transparent texture you can change this.

step 4, “press the copy button”: which copy button, there’s 5! I pressed the one in the middle one on the bottom, copy tex, I think; result: transparency in GE works, but in 3D view, I get a white silhouette instead of a regular view of the model.

Yes there are 5 copy buttons. But only 2 with the name Copy. You need to press the button in the line of the text “Active Face Alpha (Transp)”
But in the changed file I have aleady done this.