Simple question on glass material

Hi all,

I’ve been modelling an aircraft of my own. At a given time the windshield stopped being completely transparent, and now it looks more like tinted glass. You can see the material properties on the right, and as far as I know there is nothing there that should make it look so opaque to light. Let me state here that I am still a beginner with blender, so I don’t know what all buttons do.
The object is just a simple mesh with a subsurf and solidify modifiers. Any idea of what is making it so dark?

Hi :), my first tip is to try making the glass material colour completely white, chances are at the moment it’s just off white, so it’s not quite transmitting all light. Also I’ve noticed your IOR value is 1 for some reason, make sure that stays at 1.4 when doing glass.
Hope this helps :slight_smile:

Hi, as @enigma246 said, change glass color to RGB (1.0,1.0,1.0). Remove the glossy node. If you want to customize glossiness in a glass use a mix with refraction and glossy shaders, and a Fresnel node for mixing them. And increase the IOR. For small objects, 1.4 causes too much image deformation. I would use 1.75.

Other option is mixing between glass and transparent node, using light path as factor.

That didn’t solve the problem. One issue that I found is the light coming from the cloudy background, which is just a plane with an image on it, can’t go through the glass. However, this glass is transparent to other objects.
Anyway, I’m guessing that the problem here is the messy blend file I have by now. I should probably start from scratch because there must be some stuff I left behind causing these problems.
Thank you for your answers guys.

On this page you can find a book, which describes with all details how to set up such an airplane plexiglass material in Cycles, and along all other aircraft materials (“Virtual Airplane - Excerpt III: Materials and Textures”)

can you upload sample file may be so we can test it

but it looks to me that the glass should be first on mix node