Sketchup (SKP) importer

Very much thanks for the script.

Thx for the feedback.

Maybe this is what you meant by “current render engine is set to Cycles by importer”…

I ment the importer switched the current render engine to Cycles as it relies on it being set to import cycles materials.

I have no plans for an exporter as the person I wrote this for need the importer most. And besides I need to finish cycles patches that have been cooking to long.

The only thing I do have planned is split normals. And fixing the known issues.

Hi, I’m new on Blender, usually I use Sketchup for modeling and this add it could be a great solution to my workflow but when I try to import a very simple .skp model it appears this error message:

File “/Users/Oxer/Library/Application Support/Blender/2.74/scripts/addons/sketchup_importer/”, line 635, in execute
return SceneImporter().set_filename(keywords[‘filepath’]).load(context, **keywords)
File “/Users/Oxer/Library/Application Support/Blender/2.74/scripts/addons/sketchup_importer/”, line 166, in load
File “/Users/Oxer/Library/Application Support/Blender/2.74/scripts/addons/sketchup_importer/”, line 190, in write_duplicateable_groups
max_depth = max(self.component_depth.values())
ValueError: max() arg is an empty sequence

How I can solve the problem? This addon is very useful for me, I hope you can help me.

Mac OS X 10.10.3, Blender 2.74 and Sketchup 2015

Hi Juicifruit,

thanks for sharing your addon :slight_smile: Some beta-testing gave following bugs:
Some UVs are distorded:

Some faces are invisible in OpenGL, other are transparent, but all render solid in cycles (windows too):

Here is the skp file:

Kind Regards


Thank you very very much.


Confirming the issue with UVs.
Always happening when a door / window or other openings exist.
Selecting all these faces and re unwrapping in UV editor fixes it.
Selecting the problematic triangle and trying to join it with another leads to a mess.
Anyway here’s a simple wall.skp file, to test it.

And a surprise.
An excellent skp model of ancient rome.
A ~2.5 M faces skp.
The plugin at its best. Excellent.

In this scene, some of the roofs have the bug. How do you re-unwrap and keep the original scales at the same time? I tried every possibility in the U menu, they all break the scales.

Ill try to look at this and just make it import correctly.

Any simplified examples of a sketchup file that imports incorrectly ( as minimal example as you can make it while still showing the issue ) are very welcome and greatly reduce the time it will take me to fix this.

Thank you Juicyfruit, the file here : from Michaelis has the bug, I can confirm, and is simple also.

Thanks for the add-on, it works perfectly!
say Hi to Steve :smiley:

Hey Juicyfruit!
thanks a lot for such great add-on!
it is working great for me, I confirm some UVs issues
used sketchup 2015 (win) blender 2.74

I am trying to instal the plugin, but I am not sure in what folder in sketchup I need to added. Is it into the plugins folder or in the imports folder in sketchup directory?


rosatti, you have to install it in Blender directory inside the addons folder

it would be great if can to do “save as *.skp”

Hi Alain could you share more detail on hiw did yoy succesfully install this script?

What about making it a bit commercial undertaking AND polishing for effective and non-problematic import (from mac and win) ??

I declare a purchase 1st )))

Update: installation error problem solved. Fresh upgrade from 2.70a to 2.74… It seems version 2.70a caused this error

Any news to that?
I cant import ANY textured model into Blender since.

AMAZING amazing amazing job my friend.
Thank u so much for working on this.

there are any plans to import the mesh as ngons in the future?
can’t wait to see this on it’s final form

Below is another error log-this time from OSX Yosemite (iMAc).
Guys, what can be possibly wrong so I cant import any textured arch. model into Blender?
(There are nested, textured components and components from Warehouse also)