Skin SSS


at the moment I’m trying to learn creating a realstic skin shader with blender.

I’ve painted a skin with substance painter, but I have some issues with the SSS.

From what I figured out that Random Walk (Fixed Radius) is legacy and Random Walk should be used. But maybe I’m wrong here?

However, while I get some okaisch SSS result with Random Walk , I have an issue with Random Walk (Fixed Radius).
The is SSS where it’s looks off, like on the chin in the shadow:

If I reduce the SSS than SSS is too weak on thin parts like ears.

Currently this is my shader setting:

Any hint’s what the best pratice to get rid of the SSS on the chin without painting a mask?

okay, I figured it out. It was caused by the Specular (didn’t have done the maps yet so far). Should be fixed as soon I have Roughness/Specular maps.