Sloooow Blender

I’m having the most frustrating evening with Blender. I haven’t used it in several months due to some other commitments, so I downloaded and installed 2.49a and the Python update.

However, when I try to use it, it will work fine for a few moments, then the cursor will seemingly freeze, only to come back a few moments after that and let the cursor move normally.This will repeat at irregular intervals of never more than ten seconds, making using the program impossible. Things that trigger this are trivial, like box-selecting a cube and a low-poly sphere.

I’m assuming it’s an OpenGL problem, but I’m running the latest nVidia drivers for the GeForce 7600 GT and this is verified by running the GL test script in the FAQ. I’ve tried stepping back to previous editions of Blender and Python which worked fine on this very machine a few months back, only to find that they are now doing it, too.

The only thing I can think of that might be related was that I was using SketchUp for a favor to a friend and found that I needed to turn off hardware acceleration (within SketchUp, not nVidia control panel) in order for it to run OpenGL even passably well.

I’m not certain this had anything to do with my current predicament, but it’s the only recent change I can recall…

Any advice much appreciated…

what are your specs

(OS, graphics card etc)

Ooops, thought that was part of my sig.

Home-build WinXP Pro 64-bit SP2
2 X Intel 1867 MHz
nVidia GeForce 7600 video card

Things may be more serious than I thought.

Continuing to work with Blender after a fresh install of the drivers led to a “black screen”-crash, ie, no output at all and no way to get it back. I’m going to look into rolling back the drivers.

Still, any suggestions much appreciated…

this the driver you have?

In my mind I think there are three things you can do to fix this. A) Run blender - go to task manager - go to process and set priority to realtime for the blender process. B) Reinstall blender C) get a faster computer.

That’s the one. It shows up in Blender as the nVidia driver, and OpenGL version (I can’t get Blender to work long enough now to load the .py file and find out).

OK, I took the driver back in time to one of the 9x.xx drivers–same effect–Blender seems to launch a little slowly, works OK, then freezes for a few moments whenever anything interesting is done onscreen. The weird difference with the older driver was that the cursor didn’t lock up, just the display. That’s a distinction without a difference, as they say, since it’s still useless to me.

I uninstalled the older driver, rebooted and, before reinstalling the latest driver, had a go at running Blender with the default Windows display driver. It was hideously low-rez and pixelated, but it ran flawlessly.

Installed the latest driver, same problem comes back. This is getting beyond frustrating.

Maya works fine, if that’s any hint. My thinking is that it’s something in the interaction of Blender and my particular configuration, the data being:
1.) Blender works great with the default driver.
2.) Blender doesn’t work with old drivers (that it used to work with).
3.) Other OpenGL applications seem to work OK.

Any suggestions much appreciated.

I’ve done a fair bit of looking on-line and came up with zip - sorry

it most likely there was a windows update that doesn’t agree with Blender and/or your driver

the only thing I can suggest to confirm this is to roll back the old driver and the old version of Blender
if it doesn’t work - it most likely a Windows update that has broken it

if it does work - you can do a little celebration dance

Thanks so much for all your help!

Considering the PITA-factor of the downgrade, the more general OpenGL flakiness (the aforementioned SketchUp problem) and the age of the card, I’ve decided to just go and order a new(ish) card from NewEgg–A Sapphire HD4650, ATI-based card. I’ve had pretty good luck with the brand (except on Ubuntu ;-))

Thanks again, and I’ll post how it goes when installed.

do some research first - there are a few known problems with ATI and blender

Research? Precaution? Common sense? Me?

I do know about the problems with ATI closed drivers and open source incompatibility, but I figured, “What the heck?”

I just installed a Sapphire Radeon 4650 and I must say that Blender is running dreamily.No problems, no stuttering. If it does conk out, though, I have another box currently out at the shop that runs nVidia that I can switch over to at need. I just need to get reacquainted with Blender, not drive it into the ground :wink:

Right now, my main problem is that the nVidia “Forceware” won’t uninstall completely. sigh

Thanks again for all your help–I’m sorry to have cost you any time at all, and hope I can return the favor some time.

thanks - but I didn’t actually help you at all

I glad you got Blender working

if you are stuck with trying to reacquaint yourself with Blender
you are at the right place

that’s what the forum is meant for :wink: