Smart Config - Import export full blender configuration with addons in one click

Hum, I think I’m using blender rc2 at home, I’ll try to install the latest version tonight. Anyway, a big thank you :slight_smile:

Edit: so I tried to install the zip file (1.0.1) from the link you last sent and it didn’t work. I did download the one from your main github page and it seems to work. go figure… gonna try at home tonight.

So, let’s see…
The installation from github master version works, the release doesn’t, that’s because of dots in the name: the addon installs but cannot be seen. Just change the name, and remove the dots. (And capitals, too!)
I’ve exported everything from 2.79, and imported into 2.79a, a version I use for testing, should be the same (it is?)
I’ve got an error on importing for an addon, sverchok:

do I have to disable it, or put into the excluded list on your addon config page?
Moreover, I don’t see modification. Maybe the import process aborted on this error? What should I check?
Log doesn’t show errors

EDIT: a folder named sc_temp has been created into the dir in which I saved It contains all the setup I saved.

Both Sverchok and Animation Nodes have special setup. More on that later.

Hi ! yep i saw this with the github release system, should be ok right now, i’m not used to this yet !
For the error on sverchok, i’m trying to handle it, but it comes from the sverchok addon, i get the same error when activate/deactivate it sometimes !

And yep the addon create a temp folder which is removed at the end, if the process crashes for some reason (like the sverchok error), it doesn’t delete it ! i’m going to try to handle this also ! working on bugfixes !

sorry about this “beta test” guys, and thanks for all the feeds ! :smiley:

Hi guys !
Here’s a new bugfixes release :

Should handle a lot of reported errors better ! It also delete the temporary folder even if the export failed !

Tell me how it works on your workstation !

Cheers !

if this error appear, deactivate sverchok, restart blender and activate it again. will work
We have also some folder in Blender\2.79\datafiles\sverchok
it contain all user datafiles of us also user presets.

Thanks for the tip !
i’ll add the datafiles in the next version to be sure to bring all presets… for now it just brings the “presets” folder

Exported from 2.79, opened 2.79a rc, reset to factory, deleted all addons in their folder.
Imported, work. It imported all addons, exactly as they where. Even things like tab panel.
Reload default config, and it’s identical to the original one.
Good job.

Wait, one thing is missing: keyconfig has been skipped and my precious os X setup ended up copied into preset directly, not in preset/keyconfig.
Same destiny for keyconfig/operator. They’re with all other default blender preset.
Overall, it’s impressive, anyway.

About animation nodes: the addon is platform-dependent. It has low level C bindings and cannot be copied, say, from windows to os X. I think it’s straightforward within the same platform.

Oh yep i didn’t see this bug in recursive folder copy, here it is :

it should fix your keyconfig problem and the config problem too ! :smiley:

And about animation nodes (and all blender addons os dependant), that’s why i add a custom property in the user prefs to avoid some addons ! if you want to make a config for windows to windows with AN, you can copy it, otherwise, just add it in the string !
While saying i’m realizing the export windows should have this field too… for the next release :smiley:

And i’ll also add the copy datafiles ability for sverchock presets for example !

Finally the addon seems to be usable, sorry about all these little errors, a while since i didn’t do python coding :smiley:

cheers !

Any video or help. How to use or how it works

So, I tried once again, now presets directory is in the right place.
Sverchok is imported fine except for a couple of user dirs
Animation nodes too
I noticed a quirk; some addons gets imported correctly, but their setup is not; they’ve to be setup again (tab panel, mouselook navigation).
Can it be because those addons record something in userpref, and I did factory restore?
That’ strange anyway, because for instance mouselook records its preferences into the addon dir itself and that has been copied…

I don’t know if you have noticed, but restoring the exported configuration into a new one removes corruption from userprefs. I had a corrupted one who gave me errors, and now they are gone. This is VERY GOOD, because userpref corruption is a source of headaches, blend function failures, plugin misinstallation and conflict, and remade-from-scratch reinstallations which cause losing a lot of time.
This addon should be proposed for inclusion into Blender.

Hi ! glad it eventually worked :wink:

so about sverchock, yep it’s because of some user folder in the datafiles dirs, i’ll add datafiles migration in the next version !
about addons prefs, for now it’s totally nomal, the addon doesn’t get these preferences (in the user prefs) ! i’ll take a look on that for next version !

and cool for the removing corruption thing ! basically, it makes sure addons which are deactivate are totally unregistered before reactivating them, i think that’s why corrupted user prefs are fixed !

i didn’t expect this, it’s a very good news ! thanks for the feedback ! :smiley:

EDIT : i had a look for the addon preferences issue, it should normally works (if you do not reset factory settings) because they seems to be stored in blender user prefs file !

Hey guys !
here the last release of smart-config, v1.1.0 !

The changes :

Changes in the user preferences, you have now the ability to see addons which are not exported, and select trunk exceptions to avoid automatically those in the 2.79 blender trunk

Datafiles are now exported/imported. Plugins like Sverchock have some configuration and presets files in them

When exporting, you can now see the list of addons which are going to be included, and exclude some of them on-the-fly

You have now in user preferences and export settings a little operator to print in console the list of exported addon (with module name)
Warning : this list does not take into account the per addon exclusion settings in export operator

I’ll try to make a little documentation, and video or explanatory gif as soon as i can ! Thanks again for feedbacks, the addon seems to be really decent right now thanks to them !

Cheers !

1 Like

Hi guys !
Here’s a little howto/demo video !
The addon seems quite stable now, tell me what you think :smiley:

Today I had to recreate my Blender configuration to setup a test/development copy. I did the same couple of week ago, but the manual process (just for the sake of checking everything). I exported the conf manually and then with your addon. Then I imported it manually in default installation and with your addon in test installation (obviously they are the same). Results: manually: 4 hours, your addons: 4 seconds.
It even works with those complicated addon like Sverchok. No errors. Same configuration replicated.
Again thank you for this very good tool. As I said before, it should be in Blender trunk.

1 Like

Hi thanks for the follow up :slight_smile: Really happy to hear that it helped !
cheers !

I catch this add-on on BA ads

Support 2.8 ?

1 Like

hey not yet, i’ll do it asap when i got free time :wink:

1 Like

Hi. Have you started working on the blender 2.8 compatibility ?
I can’t wait to be able to use this addon. Please, please, please :slight_smile:

hi thanks for your interest :wink: nop not yet have the time, i am still in the middle of a production, hard to get some spare time right now ! it is on the to do list, i’ll keep you posted, cheers !

1 Like

Does it work for 2.9?