Smart UV Project not working after splitting meshes


i’ve split a large object (interior wall) into 3 sections because I wanted to apply 3 different maps to get better resolution and quality when baking it. Unfortunately, when I try to unwrap the wall now with Smart UV Project I get this very weird result where the whole map consists out of triangles layed on top of each other.

Before splitting it, the Smart UV Project function was working just fine. Has anyone an idea how to fix this? Removing the UV Map and adding a new one didn’t chang it unfortunately.

I don’t know about the UV Project, I rarely use it. But your mesh look triangulated, so you have to get triangular UVs as well.

But I would try to clean up a bit to get quads wherever possible (knife tool to get only straight lines, reposition accurately, then dissolve excess lines). Then for thew wall itself I would use projectfromview, add a single seam in the window loop and unwrap those by themselves as a strip.

The problem also appears with rectangular meshes (I split up a single wall that only consists of cuts at the edges and the UV Project functino just shows a rectangle instead of several rectangles for each side).

Share the wall. I’m out of guesses.

For example the red wall (I moved it up). Maybe you can find a solution.

Only that it worked for me - select all triangular faces in edit mode (I would clean that up), then just Smart UV Project with default settings. I deleted all the other stuff for my own convenience.

Unrelated, but you might want to check your units/scale. The Bottom long edge of the wall is 13770 meters long. If you prefer punching in distances in mm (I do), setup the units system for mm instead. Then scale everything down and apply scales.

Thanks, that worked!