Smoke/Fire sim results wont show in viewport unless changed from "modular" to replay

Like it says on the title. Not tried simming with 3.0 up to now. Has something changed. I can bake the sim only in modular/uni cache mode with is resumable. the problem is no result is in the viewport UNLESS changed to “replay”. How do you get the best of both worlds here? I want to see it, and be able to bake/tweak/resume it without messing around?

The Is Resumable option is allowing to stop baking process at any frame.
When, baking is stopped, data has been cached for all frames until current one.
You don’t see anything during the baking process.
But after stopping the baking, you should see something in viewport for all frames until the one when you choose to stop.

If you are happy, you can resume simulation with same settings or free cache.
You cannot bake a part of the cache, tweak settings and bake the rest.
The cache system does not allow that.

Currently, you have to accept to rebake first satisfying frames to tweak last unsatisfying ones with modular cache.
Modular cache just allows you to bake global settings and tweak high resolution noise and then bake noise separately.
So, if you want to animate several global settings, best choice is probably to make several tries with Replay mode.
And when it looks good, change cache mode to Modular or All and bake. Whatever cache mode is used, same settings should produce same simulation.

Geometry nodes have been introduced in 2.92. They have been redesigned in Blender 3.0. They will continue to be extended in future 3.x releases. But it is planned to create nodes for simulations.
There should be cache nodes allowing user to cache a part of nodetree. Then, it should be possible to tweak the cache with dedicated nodes.

But for the moment, you have to deal with limitations of fluid modifier.