Snap Tool Not working for me

I am using Blender 2.78A, I am following a tutorial to make a tire with treads… I have the two treads that will be in the tire created with many faces on the object.I have a straight up and down curved portion of the tire… in the tutorial, he chose Faces on the snap tool, .chose 'closest" clicked the "align rotation with snapping target… He had it in shaded view in Object mode… held the G key and the Ctrl key and then hit enter and it snapped the treads form to the tire guide… Mine does nothing… have no clue as to why it is not working…
I’m working on the Vehicle Production course from CG Masters…
I got it working once but it attached it in the wrong place and it didn’t come out right at all… so am trying to redo it and can’t get it to snap to it in the right place… it needs to snap to the tire guide right where it is in front of it… I’ve watched videos on youtube about using the snap tool, read some other stuff and can’t get it to work like he did in the Tire chapter… I’m stumped at this point…



Jeep Wrangler 4.blend (4.56 MB)

This toggle button is what you want, I think.

Thanks… this is the first time i’ve ever used the tool… I tried with that one enabled and with it disabled with the same
result… will try again…

Did you select all the verts in edit mode and g to move them?

I have tried everything… all settings… had it on verts, faces… the tutorial had the object in Verts mode, was in Edit, set the snap tool to Faces, he pressed the G key and then held the CTRL key and pressed enter… I’ve tried that and just not working… I tried it in Blender version 2.78A and 2.79… reinstalled 2.79 and still not working… sometimes I get parts of the mess snapped to the tire guide while the other parts aren’t… I’ve checked the normals, I’ve checked for doubles, a few times, soon as I pushed down the ctrl key after pressing G, it increased the size of the mesh probably 10 times their size… I am totally lost at this point as to why not working… the man who did the tutorial I’m using, had me send the file to him and it worked fine … but for me… nothing… I don’t know what to look for at this point as to why it’s not working for me… I even tried the snap tool in Blender 2.72… no luck there either…


What you describe (the scaling) happens to me if I do not toggle that third button. The last one (the one i show in the image) must be enabled (snap to other objects)

The scaling is likely happening because you need to apply scale on the tread shape. Some edit actions will be wrong in Edit Mode if there is scaling in object mode. Use ctl A/Scale to do this in Object Mode.

Other than that I am not sure what is going on here.

I had the same result as you. G and ctl Enter does nothing and even when I did get it to work it was random and never fully worked all the way. Only some points and (see below) was maybe to do with the viewport angle.

The only thing that worked consistently for me (regardless of apply scale in object mode) was to turn on at least “align individual elements…” go to front view orthographic, use the key shorts for move on the Y; G,Y and drag the mouse. It then snaps as a perfect projection on the Y. Using the perspective view seems to get different results depending on which way it is rotated. I am not sure if there is a setting for that. But it makes it appear as if it is working in a random way.

This may not be perfect but it gets a consistent result. And you can continue with your tutorial. :slight_smile:

I’ve done the scaling in Object mode and that does nothing either… I have the “align individual elements” on and that don’t work either… I made sure that I loaded factory settings to be sure something I had saved in User Preferences wasn’t messing it up… that didn’t help
I need to snap the treads to the guide tire object and the treads need to snap to it on a curve… it randomly puts verts to the guide… but not on the curve… In top view, I moved the treads to the center of the guide so it was not on the curved part and it snapped perfectly… it is not wanting to snap to the object if it is curved… not know why… I just don’t know what the solution is at this point… but it appears to be a problem with the curved part of the guide… and the treads need to be on the curved part so the right side of the treads are to the center of the guide tire so when I run the array around, the treads are on both sides as they should be…
I have never used the snap tool before so this is my first experience with it and no idea how to solve this problem…

Am learning to model and learning new things along the way with it and now am totally stumped…

have a good evening…

You know what might help me help you better is you can give me a screen shot of what the tire is supposed to look like. And I can give you some alternate methods to do this.

I am not sure why the snap tool is not working. Did you try my method to just move it while in the front view?

If it is not clear I can make a video for you.

I think you’ve already tried these things, but these are the exact steps I took:

Press 1 to enter front orthographic view. Enable ‘snap during transform’, select ‘face’ as the snap element & select ‘closest’ as the snap target. Enable ‘align rotation with snapping target’ & enable ‘project individual elements…’. Press tab to enter edit mode, press A to select all, press G then press enter.

If that doesn’t work, I’m not sure what’s going on.