Soft edge hard edge, how to?

How to make soft edges in blender?

I want smooth the following identified edges.(I don’t want to use edge split.)

In edit mode select faces and W / Shade Smooth

If you have any modifiers that control shading (edge split) or autosmooth enabled that would over ride this

Yes. But I only want to loose the edge I marked with red. Not the green one.

When I use W > Shade Smooth, I loose all edges. But I want to keep the green one. How do I do that?

Faces have the smoothing attribute, not edges. Knowing that, you should rethink your restriction about no edgesplit - it’s the only way to go for this instance that avoids faceting on the top surface.

subsurf is what I would use. delete everything above the first ring of faces and extrude with subsurf enabled. Then put edge loops and drag them closer to the edges you wish to sharpen. It will take more than one edge loop to give a smooth curve.

Well this is a game model. So, I can neither separate the parts for a hard edge nor use subsurf.

Am I out of luck?

You can mark edges with “ctr+E>mark Sharp” as sharp
in combination with the edge split modifier you can easy control your smothed and sharp parts

PS dont forget to smooth everything before and turn edge angle in the edge-split-modifier off.


edit… it could be that this modifier splits the mesh, but i dont think this would be a problem.
the engine shouldnt have problems with it.

This seems to be the only option right now. One more question, what does the Edge Angle check box do in the Edge split modifier?

I’m close to what I want. I have the following result. There is a lot of manual labor involved. Only if there was a soften edge option.

Thanks guys! :slight_smile:

Well the other option is to use multrites and bake the high poly onto the low poly. Never done it before, but I’ve seen it done in youtube video tuts.

You mean using normal map to mark hard or soft edges?

And I believe there is an incoming solution to this issue :smiley:

Check out Mont’s project:

He is working on this issue.

Here is a build with soft edge hard edge feature :

First you have to enable VBO from preference. Then to have soft edge, select face > Shade Smooth. For hard edge, select edge > Mark sharp.

But to see the hard edge you have to enable loop normal from the properties panel(N key) > item panel > check “Loop Nor”

Here is a result,

The value next to “Loop Nor” is the angle between faces.

why go to all that trouble? just go into edit mode, select the beveled loop and select shade flat from the toolbar.

oh i see what your getting at sorry there is one way to achieve that smooth bevel. control loops.

add your subsurf level 2. in edit mode make a loopcut around the cylinder and drag it up real close to the edge of the bevel do the same on the inside of the bevel then repeat for the top edge of the bevel and you get that sharp edge you are looking for. the closer you are to the edge of the bevel the sharper the crease

Well, its for game model. So, I need soft edge. I can’t really bevel too much.

but, what you are trying to smooth is a bevel!
but i see what yuor getting at, too many loop cuts could be an issue. so i can only re-suggest following earlier advice and make it as high poly as possible and bake it down to a normal map

Normal map doesn’t suit every corner. Normal map is to hold the details, not the shape. For shaping I need hard edge and to force focus the hard edge I need soft edge around it. It’s really important.

I am not trying to smooth a bevel. I won’t be using a bevel if I can control the softness of the edges.

you are trying to smooth a bevel. that slope on your mesh that you are trying to smooth… is a bevel. it will remain a bevel whether you have used a bevel tool on it or not :slight_smile:

not entirely sure how to achieve the effect you are looking for without subsurfing though