Solidify Problem in Blender 2.8

Hi.

I was testing Blender 2.8 ( download from 22 february 2019) and i found an issue with the Solidify modifier.
This is the mesh, just as an example, with the Solidify Modifier Off.

And this is with the modifier activated. If i check “even Thickness” the result get worse, so i let that Off.

In Blender 2.79 there is no problem whatsoever

The problem can be fixed if i delete the edges at the top of the geometry, but that is not something that is necessary in blender 2.79.

Any info about this?.
Thanks

I’m getting the same results in both 2.8 and 2.7…

In your 2.7 screenshot it seems lke you are just adding thickness inwards, that’s why they look different?

No, the Solidify is Outwards, take a look.

In any case the solidify issue in Blender 2.8 happens also with the solidify inwards, at least happens to me, so it makes no difference. I personally don’t have a problem with Blender 2.79. i`m using a version of 2.79 that i download from https://builder.blender.org/download/ on January 24 2019.

Hmm, it seems like the “even thickness” is broken in 2.8.

This is what happens in 2.79:

I think you should report this bug:
https://developer.blender.org/maniphest/task/edit/form/1

In the 2.8 screenshot even thickness and high quality normals haven’t been enabled. Non-the-less, it does seem to be giving different results in 2.8 compared to 2.7

1 Like

As i said in my original post:

If i check “even Thickness” the result get worse, so i let that Off.

I think “high quality normals” option doesn’t work in 2.8. I just tested similar model : “even thickness” gives 1 to 1 result in both versions, but “hq normals” does nothing in 2.8. You should report this

If i uncheck “high quality normals” in Blender 2.79 the result is very similar to the one in 2.80, so i think that “high quality normals” could be the main issue in Blender 2.80…